[PATCH i-g-t v2 08/10] lib/intel_cmds_info: Introduce render tilings
Karolina Stolarek
karolina.stolarek at intel.com
Fri Apr 26 13:18:25 UTC 2024
On 26.04.2024 11:01, Zbigniew Kempczyński wrote:> +struct
render_tiling_info {
> + uint32_t supported_tiling;
> + uint32_t supported_compressed_tiling;
> +};
> +
> struct intel_cmds_info {
> struct blt_cmd_info const *blt_cmds[__BLT_MAX_CMD];
> + struct render_tiling_info const *render_tilings;
These two structs should share the naming convention, as they describe
the same thing but for two different copy operations.
There are two ways about it -- either rename blt_cmd_info to
blt_tiling_info in a separate patch or make the render one to be
something like render_cmd_info.
All the best,
Karolina
> };
>
> extern const struct intel_cmds_info pre_gen6_cmds_info;
More information about the igt-dev
mailing list