[PATCH i-g-t] tests/intel/xe_live_ktest: Rename subtest to match suite
Lucas De Marchi
lucas.demarchi at intel.com
Wed Feb 7 18:56:59 UTC 2024
The test suite name in the kernel modules contain an xe_ prefix.
Upcoming changes for filtering will make the match more strict,
so rename the subtests to match the test suite name.
References: https://lore.kernel.org/igt-dev/3267150.N7aMVyhfb1@jkrzyszt-mobl2.ger.corp.intel.com/
Signed-off-by: Lucas De Marchi <lucas.demarchi at intel.com>
---
build tested only, let's see what CI returns
tests/intel-ci/xe-fast-feedback.testlist | 6 +++---
tests/intel/xe_live_ktest.c | 16 ++++++++--------
2 files changed, 11 insertions(+), 11 deletions(-)
diff --git a/tests/intel-ci/xe-fast-feedback.testlist b/tests/intel-ci/xe-fast-feedback.testlist
index d8fd66a45..b5e96d536 100644
--- a/tests/intel-ci/xe-fast-feedback.testlist
+++ b/tests/intel-ci/xe-fast-feedback.testlist
@@ -228,9 +228,9 @@ igt at kms_psr@psr-sprite-plane-onoff
igt at core_hotunplug@unbind-rebind
# Run KUnit tests at the end
-igt at xe_live_ktest@bo
-igt at xe_live_ktest@dmabuf
-igt at xe_live_ktest@migrate
+igt at xe_live_ktest@xe_bo
+igt at xe_live_ktest@xe_dmabuf
+igt at xe_live_ktest@xe_migrate
# Move fault_mode tests at the end to unblock execution
igt at xe_exec_fault_mode@twice-basic
diff --git a/tests/intel/xe_live_ktest.c b/tests/intel/xe_live_ktest.c
index 5f5f1dff7..4b8e60676 100644
--- a/tests/intel/xe_live_ktest.c
+++ b/tests/intel/xe_live_ktest.c
@@ -9,23 +9,23 @@
* Functionality: kunit
* Test category: functionality test
*
- * SUBTEST: bo
+ * SUBTEST: xe_bo
* Description:
* Kernel dynamic selftests to check if GPU buffer objects are
* being handled properly.
* Functionality: bo
*
- * SUBTEST: dmabuf
+ * SUBTEST: xe_dmabuf
* Description: Kernel dynamic selftests for dmabuf functionality.
* Functionality: dmabuf
*
- * SUBTEST: migrate
+ * SUBTEST: xe_migrate
* Description:
* Kernel dynamic selftests to check if page table migrations
* are working properly.
* Functionality: migrate
*
- * SUBTEST: mocs
+ * SUBTEST: xe_mocs
* Description:
* Kernel dynamic selftests to check mocs configuration.
* Functionality: mocs
@@ -37,10 +37,10 @@ struct kunit_tests {
};
static const struct kunit_tests live_tests[] = {
- { "xe_bo_test", "bo" },
- { "xe_dma_buf_test", "dmabuf" },
- { "xe_migrate_test", "migrate" },
- { "xe_mocs_test", "mocs" },
+ { "xe_bo_test", "xe_bo" },
+ { "xe_dma_buf_test", "xe_dmabuf" },
+ { "xe_migrate_test", "xe_migrate" },
+ { "xe_mocs_test", "xe_mocs" },
};
igt_main
--
2.43.0
More information about the igt-dev
mailing list