[PATCH i-g-t v3 12/13] lib/igt_drm_clients: Record total cycles

Umesh Nerlige Ramappa umesh.nerlige.ramappa at intel.com
Wed May 8 19:01:09 UTC 2024


On Fri, May 03, 2024 at 11:46:42PM -0700, Lucas De Marchi wrote:
>If the fdinfo data indicates there's drm-total-cycles, use it to
>propagate the engine utilization. Also add an assert in intel_gpu_top
>since it only knows how to deal with with engine time busyness.
>
>Signed-off-by: Lucas De Marchi <lucas.demarchi at intel.com>
>---
> lib/igt_drm_clients.c | 13 +++++++++++++
> lib/igt_drm_clients.h |  5 +++++
> 2 files changed, 18 insertions(+)
>
>diff --git a/lib/igt_drm_clients.c b/lib/igt_drm_clients.c
>index fbbb763f7..105c7d298 100644
>--- a/lib/igt_drm_clients.c
>+++ b/lib/igt_drm_clients.c
>@@ -107,10 +107,13 @@ igt_drm_client_update(struct igt_drm_client *c, unsigned int pid, char *name,
> 	c->total_engine_time = 0;
> 	c->agg_delta_cycles = 0;
> 	c->total_cycles = 0;
>+	c->agg_delta_total_cycles = 0;
>+	c->total_total_cycles = 0;
>
> 	for (i = 0; i <= c->engines->max_engine_id; i++) {
> 		assert(i < ARRAY_SIZE(info->engine_time));
> 		assert(i < ARRAY_SIZE(info->cycles));
>+		assert(i < ARRAY_SIZE(info->total_cycles));

same comment as before - maybe just ensure array sizes are the same.

>
> 		if (info->utilization_mask & DRM_FDINFO_UTILIZATION_ENGINE_TIME &&
> 		    info->engine_time[i] >= c->utilization[i].last_engine_time) {
>@@ -131,6 +134,16 @@ igt_drm_client_update(struct igt_drm_client *c, unsigned int pid, char *name,
> 			c->agg_delta_cycles += c->utilization[i].delta_cycles;
> 			c->utilization[i].last_cycles = info->cycles[i];
> 		}
>+
>+		if (info->utilization_mask & DRM_FDINFO_UTILIZATION_CYCLES &&

This should be

s/DRM_FDINFO_UTILIZATION_CYCLES/DRM_FDINFO_UTILIZATION_TOTAL_CYCLES/

or a new name if you decide to change things based on below comment.

>+		    info->total_cycles[i] >= c->utilization[i].last_total_cycles) {
>+			c->utilization_mask |= IGT_DRM_CLIENT_UTILIZATION_TOTAL_CYCLES;
>+			c->total_total_cycles += info->total_cycles[i];
>+			c->utilization[i].delta_total_cycles =
>+				info->total_cycles[i] - c->utilization[i].last_total_cycles;
>+			c->agg_delta_total_cycles += c->utilization[i].delta_total_cycles;
>+			c->utilization[i].last_total_cycles = info->total_cycles[i];
>+		}
> 	}
>
> 	/* Memory regions */
>diff --git a/lib/igt_drm_clients.h b/lib/igt_drm_clients.h
>index 514c09e71..946d709de 100644
>--- a/lib/igt_drm_clients.h
>+++ b/lib/igt_drm_clients.h
>@@ -36,6 +36,7 @@ enum igt_drm_client_status {
> enum igt_drm_client_utilization_type {
> 	IGT_DRM_CLIENT_UTILIZATION_ENGINE_TIME	= 1U << 0,
> 	IGT_DRM_CLIENT_UTILIZATION_CYCLES	= 1U << 1,
>+	IGT_DRM_CLIENT_UTILIZATION_TOTAL_CYCLES	= 1U << 2,
> };
>
> struct igt_drm_client_engines {
>@@ -74,11 +75,15 @@ struct igt_drm_client {
> 	unsigned long agg_delta_engine_time; /* Aggregate of @utilization.delta_engine_time, i.e. engine time on all engines since previous scan. */
> 	unsigned long total_cycles; /* Aggregate of @utilization.agg_delta_cycles, i.e. engine time on all engines since client start. */
> 	unsigned long agg_delta_cycles; /* Aggregate of @utilization.delta_cycles, i.e. engine time on all engines since previous scan. */
>+	unsigned long total_total_cycles; /* Aggregate of @utilization.agg_delta_total_cycles, i.e. engine time on all engines since client start. */

total_total_cycles :). I can understand that since I am looking at the 
patches in order, but there might be room for another rename, maybe:

s/c->total_cycles/c->total_engine_cycles/ (since this is how may cycles 
the client ran on the engine)

s/c->total_total_cycles/c->total_<something>_cycles/ (where <something> 
could be - "available" or "gpu".

Regards,
Umesh

>+	unsigned long agg_delta_total_cycles; /* Aggregate of @utilization.delta_total_cycles, i.e. engine time on all engines since previous scan. */
> 	struct igt_drm_client_utilization {
> 		unsigned long delta_engine_time; /* Engine time data, relative to previous scan. */
> 		unsigned long delta_cycles; /* Engine cycles data, relative to previous scan. */
>+		unsigned long delta_total_cycles; /* Engine total cycles data, relative to previous scan. */
> 		uint64_t last_engine_time; /* Engine time data as parsed from fdinfo. */
> 		uint64_t last_cycles; /* Engine cycles data as parsed from fdinfo. */
>+		uint64_t last_total_cycles; /* Engine total cycles data as parsed from fdinfo. */
> 	} *utilization; /* Array of engine utilization */
>
> 	struct drm_client_meminfo *memory; /* Array of region memory utilisation as parsed from fdinfo. */
>-- 
>2.43.0
>


More information about the igt-dev mailing list