[PATCH i-g-t 1/6] tests/intel/xe_oa: Rename check_reports to mmap_check_reports

Ashutosh Dixit ashutosh.dixit at intel.com
Tue Apr 8 18:12:05 UTC 2025


check_reports() is only used for checking reports for mmap OA buffer use
case. Rename the function to the more specific name mmap_check_reports() to
make the purpose of the function clearer and the function easier to find.

Signed-off-by: Ashutosh Dixit <ashutosh.dixit at intel.com>
---
 tests/intel/xe_oa.c | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/tests/intel/xe_oa.c b/tests/intel/xe_oa.c
index 67acc74b32..a20120881a 100644
--- a/tests/intel/xe_oa.c
+++ b/tests/intel/xe_oa.c
@@ -4246,8 +4246,8 @@ static void mmap_wait_for_periodic_reports(void *oa_vaddr, uint32_t n,
 	}
 }
 
-static void check_reports(void *oa_vaddr, uint32_t oa_size,
-			  const struct drm_xe_engine_class_instance *hwe)
+static void mmap_check_reports(void *oa_vaddr, uint32_t oa_size,
+			       const struct drm_xe_engine_class_instance *hwe)
 {
 	struct intel_xe_perf_metric_set *test_set = metric_set(hwe);
 	uint64_t fmt = test_set->perf_oa_format;
@@ -4279,7 +4279,7 @@ static void check_reports_from_mapped_buffer(const struct drm_xe_engine_class_in
 	vaddr = map_oa_buffer(&size);
 
 	mmap_wait_for_periodic_reports(vaddr, 10, hwe);
-	check_reports(vaddr, size, hwe);
+	mmap_check_reports(vaddr, size, hwe);
 
 	munmap(vaddr, size);
 }
@@ -4308,7 +4308,7 @@ static void closed_fd_and_unmapped_access(const struct drm_xe_engine_class_insta
 	vaddr = map_oa_buffer(&size);
 
 	mmap_wait_for_periodic_reports(vaddr, 10, hwe);
-	check_reports(vaddr, size, hwe);
+	mmap_check_reports(vaddr, size, hwe);
 
 	munmap(vaddr, size);
 	__perf_close(stream_fd);
-- 
2.48.1



More information about the igt-dev mailing list