[PATCH] lib/intel_compute_square_kernels: Extend compute test for ptl
Zbigniew Kempczyński
zbigniew.kempczynski at intel.com
Fri Feb 14 11:30:58 UTC 2025
On Fri, Feb 14, 2025 at 12:17:17PM +0100, Ch, Sai Gowtham wrote:
>
>
> >-----Original Message-----
> >From: Kempczynski, Zbigniew <zbigniew.kempczynski at intel.com>
> >Sent: Friday, February 14, 2025 3:40 PM
> >To: Ch, Sai Gowtham <sai.gowtham.ch at intel.com>
> >Cc: igt-dev at lists.freedesktop.org
> >Subject: Re: [PATCH] lib/intel_compute_square_kernels: Extend compute test for
> >ptl
> >
> >On Fri, Feb 14, 2025 at 07:05:18AM +0000, sai.gowtham.ch at intel.com wrote:
> >> From: Sai Gowtham Ch <sai.gowtham.ch at intel.com>
> >>
> >> Current compute square kernel tests dosen't support on PTL, this
> >> enables tests to work on PTL.
> >>
> >> CC: Zbigniew Kempczyński <zbigniew.kempczynski at intel.com>
> >> Signed-off-by: Sai Gowtham Ch <sai.gowtham.ch at intel.com>
> >> ---
> >> lib/intel_compute.c | 10 +++++++
> >> lib/intel_compute_square_kernels.c | 42
> >> ++++++++++++++++++++++++++++++
> >> 2 files changed, 52 insertions(+)
> >>
> >> diff --git a/lib/intel_compute.c b/lib/intel_compute.c index
> >> 233835c6c..5350389df 100644
> >> --- a/lib/intel_compute.c
> >> +++ b/lib/intel_compute.c
> >> @@ -1729,6 +1729,16 @@ static const struct {
> >> .compute_exec = xe2lpg_compute_exec,
> >> .compat = COMPAT_DRIVER_XE,
> >> },
> >> + {
> >> + .ip_ver = IP_VER(30, 00),
> >> + .compute_exec = xe2lpg_compute_exec,
> >> + .compat = COMPAT_DRIVER_XE,
> >> + },
> >> + {
> >> + .ip_ver = IP_VER(30, 01),
> >> + .compute_exec = xe2lpg_compute_exec,
> >> + .compat = COMPAT_DRIVER_XE,
> >
> >This entry seems to be unused at the moment.
> This entry is implemented for the future use as we had two ver's for ptl, this can be removed if needed.
> >
> >> + },
> >> };
> >>
> >> static bool __run_intel_compute_kernel(int fd, diff --git
> >> a/lib/intel_compute_square_kernels.c
> >> b/lib/intel_compute_square_kernels.c
> >> index b0912e7e4..18f90c4fe 100644
> >> --- a/lib/intel_compute_square_kernels.c
> >> +++ b/lib/intel_compute_square_kernels.c
> >> @@ -3889,6 +3889,38 @@ unsigned char xelpg_kernel_square_bin[] = {
> >> 0x00, 0x00, 0x00, 0x00
> >> };
> >>
> >> +static const unsigned char ptl_kernel_square_bin[] = {
I think this should be renamed to xe3lpg_kernel_square_bin.
After rename:
Reviewed-by: Zbigniew Kempczyński <zbigniew.kempczynski at intel.com>
--
Zbigniew
> >> + 0x65, 0xa0, 0x00, 0x80, 0x20, 0x82, 0x05, 0x1f, 0x04, 0x00, 0x00,
> >> + 0x02, 0xc0, 0xff, 0xff, 0xff, 0x40, 0x19, 0x00, 0x80, 0x20, 0x82,
> >> + 0x05, 0x1f, 0x04, 0x1f, 0x00, 0x02, 0x00, 0x00, 0x00, 0x00, 0x31,
> >> + 0x22, 0x03, 0x80, 0x00, 0x00, 0x0c, 0x05, 0x8f, 0x1f, 0x00, 0xfa,
> >> + 0x03, 0x00, 0x70, 0xf6, 0x61, 0x80, 0x24, 0x2c, 0x02, 0x00, 0x10,
> >> + 0x00, 0x66, 0x09, 0x00, 0x80, 0x20, 0x82, 0x01, 0x80, 0x00, 0x80,
> >> + 0x00, 0x02, 0xc0, 0x04, 0x00, 0x40, 0x41, 0x22, 0x03, 0x80, 0x60,
> >> + 0x06, 0x01, 0x20, 0x54, 0x05, 0x00, 0x01, 0x14, 0x02, 0x00, 0x00,
> >> + 0x53, 0x81, 0x00, 0x80, 0x60, 0x06, 0x05, 0x03, 0x54, 0x05, 0x00,
> >> + 0x06, 0x14, 0x02, 0x00, 0x00, 0x52, 0x19, 0x14, 0x00, 0x60, 0x06,
> >> + 0x04, 0x06, 0x04, 0x03, 0x0e, 0x01, 0x04, 0x01, 0x04, 0x04, 0x70,
> >> + 0x19, 0x14, 0x00, 0x20, 0x02, 0x01, 0x00, 0x04, 0x06, 0x10, 0x52,
> >> + 0x44, 0x05, 0x00, 0x00, 0x2e, 0x00, 0x14, 0x14, 0x00, 0xc0, 0x00,
> >> + 0x00, 0x88, 0x00, 0x00, 0x00, 0x88, 0x00, 0x00, 0x00, 0x61, 0x00,
> >> + 0x00, 0xb4, 0x15, 0x06, 0x10, 0x00, 0x61, 0x00, 0x08, 0xb4, 0x17,
> >> + 0x07, 0x10, 0x00, 0x69, 0x1a, 0x10, 0x00, 0x70, 0x86, 0x05, 0x19,
> >> + 0x04, 0x15, 0x20, 0x05, 0x02, 0x00, 0x02, 0x00, 0x69, 0x1a, 0x10,
> >> + 0x02, 0x70, 0x86, 0x05, 0x1b, 0x04, 0x17, 0x20, 0x05, 0x02, 0x00,
> >> + 0x02, 0x00, 0x40, 0x1a, 0x00, 0x38, 0x08, 0x19, 0x10, 0x05, 0x40,
> >> + 0x1a, 0x08, 0x38, 0x0a, 0x1b, 0x10, 0x05, 0x31, 0x23, 0x17, 0x00,
> >> + 0x00, 0x00, 0x14, 0x0c, 0x24, 0x08, 0x00, 0xfb, 0x00, 0x00, 0x00,
> >> + 0x00, 0x40, 0x00, 0x00, 0x38, 0x10, 0x19, 0x30, 0x05, 0x40, 0x00,
> >> + 0x08, 0x38, 0x12, 0x1b, 0x30, 0x05, 0x41, 0x83, 0x20, 0x20, 0x0e,
> >> + 0x0c, 0x00, 0x0c, 0x31, 0x24, 0x15, 0x00, 0x00, 0x00, 0x00, 0x00,
> >> + 0x24, 0x10, 0x08, 0xfb, 0x14, 0x0e, 0x00, 0x00, 0x2f, 0x00, 0x14,
> >> + 0x00, 0x00, 0x40, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x10, 0x00,
> >> + 0x00, 0x00, 0x61, 0x00, 0x10, 0x28, 0x14, 0x02, 0x10, 0x00, 0x31,
> >> + 0x20, 0x02, 0x80, 0x04, 0x00, 0x00, 0x00, 0x0c, 0x14, 0x20, 0x30,
> >> + 0x00, 0x00, 0x00, 0x00
> >> +};
> >
> >Shader looks correct.
> >
> >> +
> >> const struct intel_compute_kernels intel_compute_square_kernels[] = {
> >> {
> >> .ip_ver = IP_VER(12, 0),
> >> @@ -3933,5 +3965,15 @@ const struct intel_compute_kernels
> >intel_compute_square_kernels[] = {
> >> .sip_kernel = xe2lpg_kernel_sip_bin,
> >> .sip_kernel_size = sizeof(xe2lpg_kernel_sip_bin),
> >> },
> >> + {
> >> + .ip_ver = IP_VER(30, 00),
> >> + .size = sizeof(ptl_kernel_square_bin),
> >> + .kernel = ptl_kernel_square_bin,
> >> + },
> >> + {
> >> + .ip_ver = IP_VER(30, 01),
> >> + .size = sizeof(ptl_kernel_square_bin),
> >> + .kernel = ptl_kernel_square_bin,
> >
> >Same as first comment, there's no rel = 1 for PTL defined (good argument to start
> >rework for getting ver/rel from hw).
> >
> Sure, Will be removing this entry.
>
> Thanks for your comments, will be sending an other patch without these entries
> >--
> >Zbigniew
> >
> >> + },
> >> {}
> >> };
> >> --
> >> 2.43.0
> >>
More information about the igt-dev
mailing list