[PATCH i-g-t CI run 03/14] tests/intel/xe_oa: Rename oa_exp_1_millisec to oa_exponent_default

Dixit, Ashutosh ashutosh.dixit at intel.com
Sat Feb 22 00:24:30 UTC 2025


On Tue, 18 Feb 2025 12:28:01 -0800, Umesh Nerlige Ramappa wrote:
>
> Rename the global exponent to default so it can be used in different
> modes.
>
> Signed-off-by: Umesh Nerlige Ramappa <umesh.nerlige.ramappa at intel.com>
> ---
>  tests/intel/xe_oa.c | 34 +++++++++++++++++-----------------
>  1 file changed, 17 insertions(+), 17 deletions(-)
>
> diff --git a/tests/intel/xe_oa.c b/tests/intel/xe_oa.c
> index 9c74315df..e7d6ac5af 100644
> --- a/tests/intel/xe_oa.c
> +++ b/tests/intel/xe_oa.c
> @@ -299,7 +299,7 @@ static uint32_t devid;
>  static struct drm_xe_engine_class_instance default_hwe;
>
>  static struct intel_xe_perf *intel_xe_perf;
> -static uint64_t oa_exp_1_millisec;
> +static uint64_t oa_exponent_default;
>  static size_t default_oa_buffer_size;
>  static struct intel_mmio_data mmio_data;
>  static igt_render_copyfunc_t render_copy;
> @@ -514,7 +514,7 @@ static size_t get_default_oa_buffer_size(int fd)
>		/* OA unit configuration */
>		DRM_XE_OA_PROPERTY_OA_METRIC_SET, default_test_set->perf_oa_metrics_set,
>		DRM_XE_OA_PROPERTY_OA_FORMAT, __ff(default_test_set->perf_oa_format),
> -		DRM_XE_OA_PROPERTY_OA_PERIOD_EXPONENT, oa_exp_1_millisec,
> +		DRM_XE_OA_PROPERTY_OA_PERIOD_EXPONENT, oa_exponent_default,

My suggestion here would be to (a) either rename this to
oa_exponent_default_1ms, or alternatively, (b) to rename the period
argument of max_oa_exponent_for_period_lte() to period_ns. So it's clear
from the code, without having to guess, what the value of the default
exponent is.

>	};
>	struct intel_xe_oa_open_prop param = {
>		.num_properties = ARRAY_SIZE(properties) / 2,
> @@ -1089,7 +1089,7 @@ init_sys_info(void)
>
>	intel_xe_perf_load_perf_configs(intel_xe_perf, drm_fd);
>
> -	oa_exp_1_millisec = max_oa_exponent_for_period_lte(1000000);
> +	oa_exponent_default = max_oa_exponent_for_period_lte(1000000);


More information about the igt-dev mailing list