[Bug 77863] New: i965/valgrind + glxgears = More than 10000000 total errors detected

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Wed Apr 23 22:44:32 PDT 2014


          Priority: medium
            Bug ID: 77863
          Assignee: idr at freedesktop.org
           Summary: i965/valgrind + glxgears = More than 10000000 total
                    errors detected
        QA Contact: intel-3d-bugs at lists.freedesktop.org
          Severity: major
    Classification: Unclassified
                OS: Linux (All)
          Reporter: austinenglish at gmail.com
          Hardware: x86-64 (AMD64)
            Status: NEW
           Version: 10.0
         Component: Drivers/DRI/i965
           Product: Mesa

Created attachment 97867
  --> https://bugs.freedesktop.org/attachment.cgi?id=97867&action=edit
valgrind log (bzip2)

I'm trying to run the wine tests on my laptop under valgrind. When running the
graphics tests, valgrind goes nuts in the i965 driver. The first time I ran it,
It threw an error that it hit over 10 million (!) errors and was quitting.

After a couple hours playing with suppressions and eventually exluding
practically anything invoving i965/libdrm_intel.so, I was able to get results.

As a testcase, I tried valgrinding glxgears instead, and was able to reproduce
it there as well:

==19571== More than 10000000 total errors detected.  I'm not reporting any
==19571== Final error counts will be inaccurate.  Go fix your program!
==19571== Rerun with --error-limit=no to disable this cutoff.  Note
==19571== that errors may occur in your program without prior warning from
==19571== Valgrind, because errors are no longer being displayed.

to reproduce:
valgrind -q --trace-children=yes --track-origins=yes --gen-suppressions=all
--leak-check=full --num-callers=20  --workaround-gcc296-bugs=yes
--vex-iropt-register-updates=allregs-at-mem-access glxgears

let glxgears run for a few seconds, then close

valgrind 3.9.0

OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Ivybridge Mobile 
OpenGL core profile version string: 3.3 (Core Profile) Mesa 10.0.4
OpenGL core profile shading language version string: 3.30
OpenGL version string: 3.0 Mesa 10.0.4
OpenGL shading language version string: 1.30

You are receiving this mail because:
You are the QA Contact for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/intel-3d-bugs/attachments/20140424/251e179b/attachment-0001.html>

More information about the intel-3d-bugs mailing list