[Bug 80568] [gen4] GPU Crash During Google Chrome Operation

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Mon Jan 26 08:47:39 PST 2015


--- Comment #88 from Andrea Bini <andrea.bini at gmail.com> ---
(In reply to Kenneth Graunke from comment #86)
> Hi all.  I believe this should be fixed with Mesa master - specifically,
> this commit:
> commit c4fd0c9052dd391d6f2e9bb8e6da209dfc7ef35b
> Author: Kenneth Graunke <kenneth at whitecape.org>
> Date:   Sat Jan 17 23:21:15 2015 -0800
>     i965: Work around mysterious Gen4 GPU hangs with minimal state changes.
> If you're able to test with Mesa master, I'd appreciate any reports of
> whether this solved the problem for you.  It seems to have helped for me.

Hi all, I'm the reporter of this bug
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1388612 that was redirected

I've tested the fix on my machine updating the Xorg stack from
https://launchpad.net/~xorg-edgers/+archive/ubuntu/ppa A packaged version of
Mesa with the fix was released there yesterday only. Unfortunately, even though
I'd like to, I'm not able to update the system by myself as soon as a change is
committed. Cloning the Mesa repository, building and installing it is not
enough, right? Is there a "faster" method than the one I've used?

Anyway, glmark2 ideas benchmark works fine now but, in my case, the issue is
not solved yet. An application written by myself using SDL
(https://www.libsdl.org/), that before the fix used to cause the hang most of
the times, now terminates due to a failing assertion in Mesa.

The most frequent is:
SDLApp: ../../../../src/mesa/vbo/vbo_exec_draw.c:222: vbo_exec_bind_arrays:
Assertion `exec->vtx.bufferobj->Mappings[MAP_INTERNAL].Pointer' failed.

Sometimes this happens:
SDLApp: ../../../../src/mesa/vbo/vbo_exec_draw.c:278: vbo_exec_vtx_unmap:
Assertion `exec->vtx.buffer_ptr != ((void *)0)' failed.

The application works fine on another machine with a different chip. 

The billard game FooBillard++ (http://foobillardplus.sourceforge.net/) still
causes the hang immediately.
The workaround of using always_flush_cache=true and always_flush_batch=true
doesn't work with my application nor with FooBillard++. I was just able to use
it to let ideas benchmark running fine prior to the fix. I've not tested Chrome
yet but I can do it if it can be useful. 

Thank you Kenneth for the fix and for any further help. I'd really like to use
Linux on this machine for my developments. If I can help somehow let me know.

You are receiving this mail because:
You are the QA Contact for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/intel-3d-bugs/attachments/20150126/9b61b49f/attachment.html>

More information about the intel-3d-bugs mailing list