[Bug 86469] Unreal Engine demo doesn't run

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Wed Jul 22 02:41:59 PDT 2015


Samuel Iglesias <siglesias at igalia.com> changed:

           What    |Removed                     |Added
                 CC|                            |siglesias at igalia.com

--- Comment #13 from Samuel Iglesias <siglesias at igalia.com> ---
Just to mention that I tested it on my SNB laptop with today's master
(800efb0690e962750b9a072bcbab279fdaae24a1). It runs the demo very slowly but
without spilling errors.

I ran git-bisect. This is the commit that fixed it:

commit 9b577d57029bb643f2b48b80648b4f901818e93b
Author: Matt Turner <mattst88 at gmail.com>
Date:   Mon Mar 16 21:33:31 2015 -0700

    glsl: Transform pow(x, 4) into (x*x)*(x*x).

    Reviewed-by: Juha-Pekka Heikkila <juhapekka.heikkila at gmail.com>
    Reviewed-by: Kenneth Graunke <kenneth at whitecape.org>

However we still have this issue in SNB and we could hit it again in other
programs (I have not checked current status of related bugs like bug #90631 and
bug #91259).

Iago's proposal seems reasonable, What do you think about it?

You are receiving this mail because:
You are the QA Contact for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/intel-3d-bugs/attachments/20150722/a77ee6e1/attachment.html>

More information about the intel-3d-bugs mailing list