[Bug 92068] cannot install waffle on SKL-Y

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Tue Sep 22 18:09:41 PDT 2015


--- Comment #5 from Humberto Israel Perez Rodriguez <humberto.i.perez.rodriguez at intel.com> ---
(In reply to Matt Turner from comment #4)
> (In reply to Humberto Israel Perez Rodriguez from comment #0)
> > libGL error: pci id for fd 7: 8086:191e, driver (null)
> > i965_dri.so does not support the 0x191e PCI ID.
> > libGL error: failed to create dri screen
> > libGL error: failed to load driver: i965
> The PCI ID has been in Mesa since 10.5.0.
> I suspect you're not running the Mesa you think you are. 'glxinfo | grep
> Mesa' will confirm.

i confirm that the version of mesa that i have is the 10.6.7 get from (glxinfo
| grep Mesa) , as well i've noticed that if i run the command 'make check-func'
as sudo it always takes the Mesa version 10.1.3 where this version doesnt has
yet implemented the PCI ID, i think that this Mesa version is which it has by
default Ubuntu, can you confirm this please ?

Other important thing here is that when i run the command 'make check-func'
without sudo, i always have the following errors :

$make check-func
[ 50%] Built target threads_bundled
[ 50%] Built target waffle-1
[ 50%] Built target waffle_test
[ 50%] Built target gl_basic_test
test: pass:   gl_basic.glx_init
libGL: OpenDriver: trying /opt/X11R7/lib/dri/tls/swrast_dri.so
libGL: OpenDriver: trying /opt/X11R7/lib/dri/swrast_dri.so
test: pass:   gl_basic.glx_gl_rgb
libGL: OpenDriver: trying /opt/X11R7/lib/dri/tls/swrast_dri.so
libGL: OpenDriver: trying /opt/X11R7/lib/dri/swrast_dri.so
test: pass:   gl_basic.glx_gl_rgba
libGL: OpenDriver: trying /opt/X11R7/lib/dri/tls/swrast_dri.so
libGL: OpenDriver: trying /opt/X11R7/lib/dri/swrast_dri.so

and i've noticed as well that if i do a symbolic link or copy the swrast_dri.so
to the path /opt/X11R7/lib/dri/tls/, when i run the command 'glxinfo | grep
Mesa' i got 
10.1.3 Mesa version , and when run for second time the same command only libGL
ask for the path : libGL: OpenDriver: trying
/opt/X11R7/lib/dri/tls/swrast_dri.so , strange looks like that libGL does not
recognizes swrast_dri.so, I have no idea what can be.

You are receiving this mail because:
You are the QA Contact for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/intel-3d-bugs/attachments/20150923/2212df1f/attachment.html>

More information about the intel-3d-bugs mailing list