[Bug 94709] Virtual terminals freeze after some time or when Reaching X amount of used RAM

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Fri Mar 25 23:37:12 UTC 2016


            Bug ID: 94709
           Summary: Virtual terminals freeze after some time or when
                    Reaching X amount of used RAM
           Product: Mesa
           Version: 11.1
          Hardware: x86-64 (AMD64)
                OS: Linux (All)
            Status: NEW
          Severity: major
          Priority: medium
         Component: Drivers/DRI/i965
          Assignee: idr at freedesktop.org
          Reporter: xmakerenx at gmail.com
        QA Contact: intel-3d-bugs at lists.freedesktop.org

System Environment:
Kernel_version: 4.4.5
Xorg server version: 1.18.2       
Xf86_video_intel: 1:2.99.917+587+gc186d4d-1   
I am using plasma 5 with sddm.
I am using bumblebee to use switch between intel and nvidia cards.

I am having an issue where the Virtual terminals Display freeze after the
system is using about 2 Gibs of RAM , also running a game on the intel card
seem to make it happen as well and in a more early stage in the game loading

sadly there is no error that shows in jouralctl log or the dmesg log.
I have tried running lightdm and the awesome WM but still had the issue appear.
lastly I have tried running my system only on the nvidia card and could not
reproduce the issue when just running on the nvidia card leading me to suspect
it is something with the intel drivers or mesa.

Steps to Reproduce:
1. login to the system with any WM 
2. Run a game or just open programs till memory reach about 2 Gib RAM being
used(This figure seem to be very dependent on system overall memory, seems to
be about half the system memory overall RAM)
3. pass over to a tty terminal and observe it being frozen.

**   also to note when my sytem is close to 2 Gib it uses a small amount of the
but it happens whether I have swap active or not.
***  when running the game only intel card the swap is empty. 
**** The Virtual terminals appear to be frozen but still respond to login and
command but I can't see the screen update.
**** most tests I did was to run Civ 5 and see if the virutal terminal freeze
but the issue happen if I just fill the system memory and get to about to 2
** links to forum threads on the archlinux forum describing the same issue.

You are receiving this mail because:
You are the QA Contact for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.freedesktop.org/archives/intel-3d-bugs/attachments/20160325/3b3542a9/attachment.html>

More information about the intel-3d-bugs mailing list