[Bug 104983] current version, warning during make process in glsl

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Wed Feb 7 03:34:41 UTC 2018


            Bug ID: 104983
           Summary: current version, warning during make process in glsl
           Product: Mesa
           Version: unspecified
          Hardware: ARM
                OS: Linux (All)
            Status: NEW
          Severity: minor
          Priority: medium
         Component: glsl-compiler
          Assignee: mesa-dev at lists.freedesktop.org
          Reporter: randy.ransier at gmail.com
        QA Contact: intel-3d-bugs at lists.freedesktop.org

during a make, there is a warning while entering the .../mesa/src/compiler

glsl/glsl_lexer.cpp:  In function 'int yy_get_next_buffer(yyscan_t)';
glsl/glsl_lexer.cpp:3488:47 warning: comparison between signed and unsigned
integer expressions [-Wsign-compare]
  if ((int) (yyg->yy_n_chars + number_to_move) >

(it's probably more my bug, i tried to not get any intel stuff in my libraries
at all, and i think glsl is an intel thing; it's not a feature i plan on using)

the make finished fine, it was only a warning
i just want mesa3d to only get better, and better, and better... :)
anyways, my autogen command was as follows, which is probably why i was making
glsl even though i don't think i need it:

 ./autogen.sh --prefix=/usr --libdir=/usr/lib/arm-linux-gnueabihf
--with-gallium-drivers="vc4,swrast" --sysconfdir=/etc
--with-platforms="drm,x11,wayland" --with-dri-drivers="swrast"

(if i didnt specify --with-dri-drivers=(something) it tried to load intel stuff
on me)

You are receiving this mail because:
You are the QA Contact for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.freedesktop.org/archives/intel-3d-bugs/attachments/20180207/102e5ae1/attachment.html>

More information about the intel-3d-bugs mailing list