[Intel-gfx] Corruption on changing resolution

Stefano Avallone stavallo at unina.it
Mon Sep 28 12:31:56 CEST 2009

On Friday 25 September 2009 20:25:31 Carl Worth wrote:
> Excerpts from Stefano Avallone's message of Fri Sep 25 01:20:11 -0700 2009:
> > I experience a screen corruption (as shown in the attached snapshot) as
> > soon as I change resolution on my GM965 laptop with "xrandr --output
> > LVDS1 --mode 1024x768" (the original resolution is 1280x800). Also, if I
> > type something in yakuake, it is not immediately visible, but only if I
> > retract and reopen yakuake.
> ...
> > This corruption seems to only appear when using compositing effects (I
> > use KDE 4.3.1).
> >
> > This corruption happens both with current packages in Debian unstable
> > (intel 2.8.1, xserver, mesa 7.5.1) and with the recent git
> > master.
> >
> > Does anyone experience the same issues? Shall I open a bug on fd.o? If
> > you need more info, please tell me what to do.
> That sounds like a new bug to me. Thanks for testing git versions as
> well as what's in Debian unstable.
> Are you using kernel modesetting? (Loading the i915 kernel module with
> the modeset=1 option.) And have you also tried a recent kernel to see
> if the behavior is changed?
> Opening a bug report on bugs.freedesktop.org would be helpful just so
> that we don't forget the issue. I'll try to attempt to replicate the
> bug when I get the chance, (it's conference season right now with LPC
> and XDC so it will likely be about a week before I could play with
> this).
> -Carl

Thanks for your reply, Carl.
I am using KMS and I have tried with some 2.6.31-rcs, 2.6.31. 2.6.32-rc1.
It looks like this corruption does not happen when rebooting, but only when 
the laptop is turned on (would that be possible?) . I will open a bug on fd.o 
as soon as I manage to better identify the conditions that trigger this issue.


More information about the Intel-gfx mailing list