[Intel-gfx] Problems configuring unique xorg.conf file

Felix Miata mrmazda at earthlink.net
Fri Aug 27 03:56:42 CEST 2010

On 2010/08/26 23:14 (GMT) Nasa composed:

> Given Meego's setup where is the appropriate place to put the xrandr 
> commands?  I was confused on this point when I tried that before...

I know nothing about Meego other than that you are using it. :-p

> X seems to be started from 3 files in /etc/X11/xinitrc (xinitrc, 
> xinitrc-common, and Xclients)

It worked for me in openSUSE 11.3 adding everything in xinitrc near the end,
right before the actual window manager startup commands. An alternative that
worked for me was using ~/.xinitrc and leaving /etc/X11/xinit/xinitrc untouched.

> I opted to add the lines to xinitrc thus:
> xrandr --newmode "840x480_60.00"   31.25  840 864 944 1048  480 483 493 500 -hsync +vsync

> Where I have it placed now doesn't work (after removing my edited xorg.conf, I get
> the original resolution back).  So I must not understand where it should be placed.
> Could you enlighten me, *pretty please*  :}

I did more experimenting. It worked for me with no xorg.conf, modifying
nothing in /etc/X11/xinit, and putting what used to work in the monitor
section of xorg.conf into /etc/X11/xorg.conf.d/50-monitor.conf.

worked for me to get 1600x1200 instead of the 1024x768 default, but you may
need to add the above xrandr data as a Modeline in order to get your 800x480.
"The wise are known for their understanding, and pleasant
words are persuasive." Proverbs 16:21 (New Living Translation)

 Team OS/2 ** Reg. Linux User #211409

Felix Miata  ***  http://fm.no-ip.com/

More information about the Intel-gfx mailing list