[Intel-gfx] [PATCH 1/3] drm/i915: make FDI training a display function
Jesse Barnes
jbarnes at virtuousgeek.org
Wed Apr 20 17:16:44 CEST 2011
On Wed, 20 Apr 2011 07:45:08 -0700
Ben Widawsky <ben at bwidawsk.net> wrote:
> > @@ -7270,6 +7267,7 @@ static void intel_init_display(struct drm_device *dev)
> > "Disable CxSR\n");
> > dev_priv->display.update_wm = NULL;
> > }
> > + dev_priv->display.train_fdi = ironlake_fdi_link_train;
> > } else if (IS_GEN6(dev)) {
> > if (SNB_READ_WM0_LATENCY()) {
> > dev_priv->display.update_wm = sandybridge_update_wm;
> > @@ -7278,6 +7276,7 @@ static void intel_init_display(struct drm_device *dev)
> > "Disable CxSR\n");
> > dev_priv->display.update_wm = NULL;
> > }
> > + dev_priv->display.train_fdi = gen6_fdi_link_train;
> > } else
> > dev_priv->display.update_wm = NULL;
> > } else if (IS_PINEVIEW(dev)) {
>
> I prefer when the function pointer is named similarly to the function.
> Makes it easier to read/find code.
>
> (*fdi_link_train)(struct drm_crtc *crtc);
> OR
> (*link_train)(struct drm_crtc *crtc);
Yeah, fdi_link_train is probably a better name. Thanks for checking it
out.
--
Jesse Barnes, Intel Open Source Technology Center
More information about the Intel-gfx
mailing list