[Intel-gfx] [PATCH 3/4] drm/i915: rename existing overlay support to "legacy"

Chris Wilson chris at chris-wilson.co.uk
Tue Jun 7 22:59:55 CEST 2011


On Tue,  7 Jun 2011 13:07:41 -0700, Jesse Barnes <jbarnes at virtuousgeek.org> wrote:
> The old overlay block has all sorts of quirks and is very different than
> ILK+ video sprites.  So rename it to legacy to make that clear and clash
> less with core overlay support.
> 
> Signed-off-by: Jesse Barnes <jbarnes at virtuousgeek.org>
> ---
> @@ -191,7 +191,7 @@ struct drm_i915_error_state {
>  		u32 cache_level:2;
>  	} *active_bo, *pinned_bo;
>  	u32 active_bo_count, pinned_bo_count;
> -	struct intel_overlay_error_state *overlay;
> +	struct intel_legacy_overlay_error_state *overlay;
We need to change the name here as well, unless you have some
differently name error struct up your sleeve.
struct intel_sprite_error_state?

> diff --git a/drivers/gpu/drm/i915/intel_drv.h b/drivers/gpu/drm/i915/intel_drv.h
> index 3cfc391..d73e622 100644
> --- a/drivers/gpu/drm/i915/intel_drv.h
> +++ b/drivers/gpu/drm/i915/intel_drv.h
> @@ -161,7 +161,7 @@ struct intel_crtc {
>  	bool busy; /* is scanout buffer being updated frequently? */
>  	struct timer_list idle_timer;
>  	bool lowfreq_avail;
> -	struct intel_overlay *overlay;
> +	struct intel_legacy_overlay *overlay;
>  	struct intel_unpin_work *unpin_work;
>  	int fdi_lanes;
And here. Give the old code longer names, we don't want to be touching
it ever again. ;-)
-Chris

-- 
Chris Wilson, Intel Open Source Technology Centre



More information about the Intel-gfx mailing list