[Intel-gfx] [PATCH v3] drm/i915: Fix recursive calls to unmap
Daniel Vetter
daniel at ffwll.ch
Mon Oct 31 08:45:53 CET 2011
On Sun, Oct 30, 2011 at 08:16:45PM -0700, Ben Widawsky wrote:
[snip]
> -int
> -i915_gpu_idle(struct drm_device *dev)
> +int i915_gem_gpu_idle(struct drm_device *dev, bool strictly_idle)
> {
> drm_i915_private_t *dev_priv = dev->dev_private;
> int ret, i;
>
> /* Flush everything onto the inactive list. */
> for (i = 0; i < I915_NUM_RINGS; i++) {
> - ret = i915_ring_idle(&dev_priv->ring[i]);
> + ret = i915_ring_idle(&dev_priv->ring[i], strictly_idle);
One bikeshed: When introducing a new parametere all over the tree, I
prefere consistent naming for it, i.e. s/strictly_idle/defer_retirement/
...
Reviewed-by: Daniel Vetter <daniel.vetter at ffwll.ch>
--
Daniel Vetter
Mail: daniel at ffwll.ch
Mobile: +41 (0)79 365 57 48
More information about the Intel-gfx
mailing list