[Intel-gfx] [PATCH v2 0/7] drm/i915: remove pch_edp encoder state variable

Imre Deak imre.deak at intel.com
Wed May 8 12:14:01 CEST 2013


Since whether a specific eDP port is on CPU or on PCH is fixed and
depends only on which digital port it is, we don't really need state
tracking for it. So remove it and instead check for the port and if
needed the machine type (for ValleyView).

The assumption in the code before and after the change:

Before ILK there is no eDP. Starting from ILK we can have eDP ports on
port A and D:

Port A and for ValleyView port C is always a CPU side eDP port, if the
port exists.

Port D is a PCH side eDP port if there is a PCH and VBT says it's an eDP
port.

Tested only on IVB.

v2:
- reduce debug verbosity (Daniel)
- make comment about not setting the encoder type clearer (Ville)

Imre Deak (7):
  drm/i915: use enc_to_intel_dp() instead of opencoding the same
  drm/i915: hsw: replace !is_pch_edp() with port==PORT_A
  drm/i915: ilk-ivb: replace !is_pch_edp() with port==PORT_A
  drm/i915: stop using is_pch_edp() in intel_dp_init_connector()
  drm/i915: stop using is_pch_edp() in is_cpu_edp()
  drm/i915: remove is_pch_edp() helpers and state variable
  drm/i915: print DP init debug messages from a single place

 drivers/gpu/drm/i915/intel_display.c |   24 +++-------
 drivers/gpu/drm/i915/intel_dp.c      |   84 ++++++++++++++--------------------
 drivers/gpu/drm/i915/intel_drv.h     |   14 ++----
 3 files changed, 46 insertions(+), 76 deletions(-)

-- 
1.7.10.4




More information about the Intel-gfx mailing list