[Intel-gfx] [PATCH 04/62] drm/i915/bdw: Add device IDs

Chris Wilson chris at chris-wilson.co.uk
Sun Nov 3 22:58:00 CET 2013


On Sat, Nov 02, 2013 at 09:07:02PM -0700, Ben Widawsky wrote:
> @@ -367,7 +385,9 @@ static const struct intel_device_info intel_haswell_m_info = {
>  	INTEL_HSW_D_IDS(&intel_haswell_d_info), \
>  	INTEL_HSW_M_IDS(&intel_haswell_m_info), \
>  	INTEL_VLV_M_IDS(&intel_valleyview_m_info),	\
> -	INTEL_VLV_D_IDS(&intel_valleyview_d_info)
> +	INTEL_VLV_D_IDS(&intel_valleyview_d_info),	\
> +	INTEL_BDW_PCI_IDS_M(&intel_broadwell_m_info),	\
> +	INTEL_BDW_PCI_IDS_D(&intel_broadwell_d_info)

Inconsistent naming scheme post Jesse-rebase.
  
>  static const struct pci_device_id pciidlist[] = {		/* aka */
>  	INTEL_PCI_IDS,
> diff --git a/include/drm/i915_pciids.h b/include/drm/i915_pciids.h
> index 8a10f5c..d35bc0b 100644
> --- a/include/drm/i915_pciids.h
> +++ b/include/drm/i915_pciids.h
> @@ -208,4 +208,31 @@
>  #define INTEL_VLV_D_IDS(info) \
>  	INTEL_VGA_DEVICE(0x0155, info)
>  
> +#define _INTEL_BDW_PCI_ID_M(gt, id, info) \
> +	INTEL_VGA_DEVICE((((gt) - 1) << 4) | (id), info)
> +#define _INTEL_BDW_PCI_ID_D(gt, id, info) \
> +	INTEL_VGA_DEVICE((((gt) - 1) << 4) | (id), info)
> +
> +#define INTEL_BDW_PCI_ID_M(gt, info) \
> +	_INTEL_BDW_PCI_ID_M(gt, 0x1606, info), /* ULT */ \
> +	_INTEL_BDW_PCI_ID_M(gt, 0x160B, info), /* Iris */ \
> +	_INTEL_BDW_PCI_ID_M(gt, 0x160E, info) /* ULX */
> +
> +#define INTEL_BDW_PCI_ID_D(gt, info) \
> +	_INTEL_BDW_PCI_ID_M(gt, 0x160A, info), /* Server */ \
> +	_INTEL_BDW_PCI_ID_M(gt, 0x160D, info) /* Workstation */
> +
> +#define INTEL_BDW_PCI_IDS_M(info) \
> +	INTEL_BDW_PCI_ID_M(1, info), \
> +	INTEL_BDW_PCI_ID_M(2, info), \
> +	INTEL_BDW_PCI_ID_M(3, info), \
> +	INTEL_VGA_DEVICE(0x0BD0, info) /* Simulator GT1 */
> +
> +#define INTEL_BDW_PCI_IDS_D(info) \
> +	INTEL_BDW_PCI_ID_D(1, info), \
> +	INTEL_BDW_PCI_ID_D(2, info), \
> +	INTEL_BDW_PCI_ID_D(3, info), \
> +	INTEL_VGA_DEVICE(0x0BD1, info), /* Simulator GT2 */ \
> +	INTEL_VGA_DEVICE(0x0BD2, info)  /*/Simulator GT3 */

I thought we weren't adding internal simulator ids upstream?
-Chris

-- 
Chris Wilson, Intel Open Source Technology Centre



More information about the Intel-gfx mailing list