[Intel-gfx] ddccontrol doesn't work on the new kernel

dbz divide_by_zero at mail.ru
Sat Oct 26 23:37:52 CEST 2013

 Hello, Bruno

Thank you for your answer!

Yes, I use integrated on-chip video (Intel Core i5-2500K CPU) and yes, seems both kernels use the same modules.
But unhappily from your answer I don't understand what can I do to try to get working ddccontrol on my system.

If you need some additional info about my system tell me what do you need and I give it to you immediately :)
Thank you one more time!

Saturday, Oct. 26, 2013, 12:01 +02:00 from Bruno Prémont <bonbons at linux-vserver.org>:
>CCing intel-gfx as it is related to intel GPU driver and might get missed
>by intel developers on LKML.
>Looking at the linked pastebins ddcontrol seems to make use of the same
>i2c/DDC line but getting different results.
>Surprising info I see in dmesg, that does apply to both kernels, is
>that uvesafb attaches intel GPU *after* i915/KMS has done so.
>Both i915 and uvesafb seem to be modular.
>On Fri, 25 October 2013 dbz < divide_by_zero at mail.ru > wrote:
>> Hi, guys and girls!
>> I have a strange trouble with ddccontrol that I cannot identify and solve
>> for about a month, so I hope you'll be able to help me.
>> So, I'm using LMDE system ( http://linuxmint.com/start/debian/ ). Initially
>> the kernel was 3.2.32, and ddccontrol worked perfectly with my Philips
>> 232E2SB. I was able to change monitor brightness through ddccontrol
>> commands and I was really happy :)
>> Then I upgraded my system to Update Pack 7, and the new kernel became of
>> version 3.10.5. On new kernel ddccontrol doesn't work anymore, but it still
>> works on the old one (so this isn't software issue).
>> I have checked kernel configs - for the old kernel and for the new one.
>> Both configs are identical at i2c sections. I've tried to use old (3.2.32's
>> one) config with the new kernel, but there was no success.
>> To be absolutely sure that the problem isn't in the this specific kernel
>> version (3.10.5), I've downloaded the latest one (3.11.3) from kernel.org and
>> tried to use old config on this new kernel, but the issue is still
>> reproducing...
>> It would be great if you can give me right direction on this issue, 'cause
>> I don't know what to do now... I really need new kernel and ability to use
>> ddccontrol.
>> P.S. Additional info:
>> ----------------------------
>> The output of 'i2cdetect -l' on the old kernel (3.2.32):
>>  http://pastebin.com/SqDPcwS9
>> The same on the new one (3.10.5):  http://pastebin.com/YCTmX90m
>> The output of 'ddccontrol -p' on the old kernel (3.2.32):
>>  http://pastebin.com/QL0fAZVC
>> The same on the new one (3.10.5):  http://pastebin.com/vZ4bALmt
>> And dmesg outputs for both 3.2.32 and 3.10.5 kernels:
>> - 3.2.32:  http://pastebin.com/7ijujvkA
>> - 3.10.5:  http://pastebin.com/t1wdKrAd
>> I really need someone's help with ddccontrol. It would be great if you or
>> someone else who do you know can help me :)
>> Thank you in advance!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/intel-gfx/attachments/20131027/bf91e4f8/attachment.html>

More information about the Intel-gfx mailing list