[Intel-gfx] [PATCH v2] drm/i915: Match debugfs interface name to new RPS naming

Ben Widawsky benjamin.widawsky at intel.com
Mon Mar 31 20:08:13 CEST 2014


On Mon, Mar 31, 2014 at 11:30:02AM +0530, deepak.s at linux.intel.com wrote:
> From: Deepak S <deepak.s at linux.intel.com>
> 
> Let's change the i915_cur_delayinfo to i915_frequency_info to be in sync
> with new RPS naming convention.
> 
> v2: Add "i915_frequency_info" as debugfs interface name (Ben)
> 
> Signed-off-by: Deepak S <deepak.s at linux.intel.com>

Provided that nobody cares about debugfs as an ABI -
Reviewed-by: Ben Widawsky <ben at bwidawsk.net>

> ---
>  drivers/gpu/drm/i915/i915_debugfs.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/gpu/drm/i915/i915_debugfs.c b/drivers/gpu/drm/i915/i915_debugfs.c
> index 1a35215..e5d9a902 100644
> --- a/drivers/gpu/drm/i915/i915_debugfs.c
> +++ b/drivers/gpu/drm/i915/i915_debugfs.c
> @@ -966,7 +966,7 @@ static int i915_rstdby_delays(struct seq_file *m, void *unused)
>  	return 0;
>  }
>  
> -static int i915_cur_delayinfo(struct seq_file *m, void *unused)
> +static int i915_frequency_info(struct seq_file *m, void *unused)
>  {
>  	struct drm_info_node *node = (struct drm_info_node *) m->private;
>  	struct drm_device *dev = node->minor->dev;
> @@ -3786,7 +3786,7 @@ static const struct drm_info_list i915_debugfs_list[] = {
>  	{"i915_gem_hws_bsd", i915_hws_info, 0, (void *)VCS},
>  	{"i915_gem_hws_vebox", i915_hws_info, 0, (void *)VECS},
>  	{"i915_rstdby_delays", i915_rstdby_delays, 0},
> -	{"i915_cur_delayinfo", i915_cur_delayinfo, 0},
> +	{"i915_frequency_info", i915_frequency_info, 0},
>  	{"i915_delayfreq_table", i915_delayfreq_table, 0},
>  	{"i915_inttoext_table", i915_inttoext_table, 0},
>  	{"i915_drpc_info", i915_drpc_info, 0},
> -- 
> 1.9.1
> 

-- 
Ben Widawsky, Intel Open Source Technology Center



More information about the Intel-gfx mailing list