[Intel-gfx] [PATCH 2/8] drm/i915/skl: Use a more descriptive parameter name in skl_compute_plane_wm()
Damien Lespiau
damien.lespiau at intel.com
Tue Oct 14 18:31:00 CEST 2014
What we're talking about here is the DDB allocation (in blocks). That's
more descriptive than 'max_page_buff_alloc'.
Signed-off-by: Damien Lespiau <damien.lespiau at intel.com>
---
drivers/gpu/drm/i915/intel_pm.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/gpu/drm/i915/intel_pm.c b/drivers/gpu/drm/i915/intel_pm.c
index 016b54e..475a3d4 100644
--- a/drivers/gpu/drm/i915/intel_pm.c
+++ b/drivers/gpu/drm/i915/intel_pm.c
@@ -3329,7 +3329,7 @@ static void skl_compute_wm_pipe_parameters(struct drm_crtc *crtc,
static bool skl_compute_plane_wm(struct skl_pipe_wm_parameters *p,
struct intel_plane_wm_parameters *p_params,
- uint16_t max_page_buff_alloc,
+ uint16_t ddb_allocation,
uint32_t mem_value,
uint16_t *res_blocks, /* out */
uint8_t *res_lines /* out */)
@@ -3353,7 +3353,7 @@ static bool skl_compute_plane_wm(struct skl_pipe_wm_parameters *p,
p_params->bytes_per_pixel;
/* For now xtile and linear */
- if (((max_page_buff_alloc * 512) / plane_bytes_per_line) >= 1)
+ if (((ddb_allocation * 512) / plane_bytes_per_line) >= 1)
result_bytes = min(method1, method2);
else
result_bytes = method1;
--
1.8.3.1
More information about the Intel-gfx
mailing list