[Intel-gfx] [PATCH] drm/mode: document path property and function to set it.
Daniel Vetter
daniel at ffwll.ch
Wed Oct 22 10:08:56 CEST 2014
On Wed, Oct 22, 2014 at 12:11:24PM +1000, Dave Airlie wrote:
> From: Dave Airlie <airlied at redhat.com>
>
> These two didn't get documented properly, do so.
>
> Pointed out by Daniel.
>
> Signed-off-by: Dave Airlie <airlied at redhat.com>
> ---
> Documentation/DocBook/drm.tmpl | 9 ++++++++-
> drivers/gpu/drm/drm_crtc.c | 10 ++++++++++
> 2 files changed, 18 insertions(+), 1 deletion(-)
>
> diff --git a/Documentation/DocBook/drm.tmpl b/Documentation/DocBook/drm.tmpl
> index bacefc5..0a5cbbb 100644
> --- a/Documentation/DocBook/drm.tmpl
> +++ b/Documentation/DocBook/drm.tmpl
> @@ -2509,7 +2509,7 @@ void intel_crt_init(struct drm_device *dev)
> </tr>
> <tr>
> <td rowspan="21" valign="top" >DRM</td>
> - <td rowspan="2" valign="top" >Generic</td>
> + <td rowspan="3" valign="top" >Generic</td>
> <td valign="top" >“EDID”</td>
> <td valign="top" >BLOB | IMMUTABLE</td>
> <td valign="top" >0</td>
> @@ -2524,6 +2524,13 @@ void intel_crt_init(struct drm_device *dev)
> <td valign="top" >Contains DPMS operation mode value.</td>
> </tr>
> <tr>
> + <td valign="top" >“PATH”</td>
> + <td valign="top" >BLOB | IMMUTABLE</td>
> + <td valign="top" >0</td>
> + <td valign="top" >Connector</td>
> + <td valign="top" >Contains topology path to a connector.</td>
> + </tr>
> + <tr>
> <td rowspan="1" valign="top" >Plane</td>
> <td valign="top" >“type”</td>
> <td valign="top" >ENUM | IMMUTABLE</td>
> diff --git a/drivers/gpu/drm/drm_crtc.c b/drivers/gpu/drm/drm_crtc.c
> index 90e7730..363301c 100644
> --- a/drivers/gpu/drm/drm_crtc.c
> +++ b/drivers/gpu/drm/drm_crtc.c
> @@ -3980,6 +3980,16 @@ done:
> return ret;
> }
>
> +/**
> + * drm_mode_connector_set_path_property - set tile property on connector
> + * @connector: connector to set property on.
> + * @path: path to use for property.
> + *
> + * This creates a property to expose to userspace to specify a
> + * connector path. This is mainly used for DisplayPort MST where
> + * connectors have a topology and we want to allow userspace to give
> + * them more meaningful names.
> + */
The
* Returns:
* Zero on success, error code on failure.
boilerplate is missing, with this is
Reviewed-by: Daniel Vetter <daniel.vetter at ffwll.ch>
> int drm_mode_connector_set_path_property(struct drm_connector *connector,
> char *path)
> {
> --
> 2.1.0
>
> _______________________________________________
> Intel-gfx mailing list
> Intel-gfx at lists.freedesktop.org
> http://lists.freedesktop.org/mailman/listinfo/intel-gfx
--
Daniel Vetter
Software Engineer, Intel Corporation
+41 (0) 79 365 57 48 - http://blog.ffwll.ch
More information about the Intel-gfx
mailing list