[Intel-gfx] [PATCH -v3 0/4] split plane's updates functions into check() and commit()
Gustavo Padovan
gustavo at padovan.org
Wed Sep 3 22:10:14 CEST 2014
From: Gustavo Padovan <gustavo.padovan at collabora.co.uk>
This is the beginning of the work to prepare i915 for the upcoming
atomic modesetting API. Here we split the plane update fucntions in
the check and commit states.
v2: use struct intel_plane_state to keep states between check and
commit stages.
v3: take Ville's comments
- rename pstate to state
- get rid of non-drm_rect coordinates in intel_plane_state
- keep 'clip' const
Gustavo Padovan (4):
drm/i915: create struct intel_plane_state
drm/i915: split intel_update_plane into check() and commit()
drm/i915: split intel_cursor_plane_update() into check() and commit()
drm/i915: split intel_primary_plane_setplane() into check() and
commit()
drivers/gpu/drm/i915/intel_display.c | 234 +++++++++++++++++++-------------
drivers/gpu/drm/i915/intel_drv.h | 12 ++
drivers/gpu/drm/i915/intel_sprite.c | 253 +++++++++++++++++++++--------------
3 files changed, 301 insertions(+), 198 deletions(-)
--
1.9.3
More information about the Intel-gfx
mailing list