[Intel-gfx] [PATCH 00/11] drm/i915: VBT/opregion refactor to support >6 KB VBT

Jani Nikula jani.nikula at intel.com
Mon Dec 14 02:50:44 PST 2015


This series refactors the VBT and OpRegion code to support VBT bigger
than 6 KB. It's plenty of small, hopefully easy to review steps.

This series supersedes patches 2-6 of Deepak's series [1]. I took over
because I would not have been able to adequately describe in review what
I wanted done.

I'll continue with rebasing the rest of the patches on top of this one.

BR,
Jani.


[1] http://mid.gmane.org/1448923632-16760-1-git-send-email-m.deepak@intel.com


Deepak M (1):
  drm/i915: Add Intel opregion mailbox 5 structure

Jani Nikula (10):
  drm/i915: move "no VBT in opregion" quirk to intel_opregion_setup()
  drm/i915/bios: have functions return vbt, not bdb, header pointer
  drm/i915/bios: move debug logging about VBT source to
    intel_parse_bios()
  drm/i915/bios: rename intel_parse_bios to intel_bios_init
  drm/i915: refactor VBT validation
  drm/i915/opregion: make VBT size limit more strict
  drm/i915/opregion: make VBT pointer a const
  drm/i915: don't use a temp buffer for opregion debugfs file
  drm/i915/debugfs: add a separate debugfs file for VBT
  drm/i915/opregion: handle VBT sizes bigger than 6 KB

 drivers/gpu/drm/i915/i915_debugfs.c   |  31 ++++++---
 drivers/gpu/drm/i915/i915_dma.c       |   2 +-
 drivers/gpu/drm/i915/i915_drv.h       |   8 ++-
 drivers/gpu/drm/i915/intel_bios.c     | 117 ++++++++++++++++------------------
 drivers/gpu/drm/i915/intel_bios.h     |   2 -
 drivers/gpu/drm/i915/intel_opregion.c |  66 ++++++++++++++++++-
 6 files changed, 151 insertions(+), 75 deletions(-)

-- 
2.1.4



More information about the Intel-gfx mailing list