[Intel-gfx] [RFC 0/7] start hiding away vbt structure from the driver

Jani Nikula jani.nikula at intel.com
Tue Dec 15 07:33:31 PST 2015


The VBT is a monster and it keeps growing. Originally we've extracted
bits and pieces out of there, and added them cleanly to our own
structures in dev_priv->vbt, with our own macros. Later on we've been
slipping and we have copied stuff from VBT verbatim, using the same
structs and defines as in VBT.

Start abstracting the VBT more, hiding away the VBT specific stuff that
should not be fiddled with outside of intel_bios.c. Make it more
explicit when we're doing so. At this stage, mostly just fork the
private parts into intel_bios_private.h. As prep work, move some stuff
to intel_bios.c to limit the amount of macros needing to be exposed
across the whole driver.

I think this is the right direction, but this has plenty of bikeshedding
potential. Therefore here's an early RFC. This is based on [1] but the
conflicts are small.

BR,
Jani.


[1] http://mid.gmane.org/cover.1450089383.git.jani.nikula@intel.com




Jani Nikula (7):
  drm/i915: move drmP.h include to i915_drv.h
  drm/i915: move VBT based TV presence check to intel_bios.c
  drm/i915: move VBT based LVDS presence check to intel_bios.c
  drm/i915: move VBT based eDP port check to intel_bios.c
  drm/i915: move VBT based DSI presence check to intel_bios.c
  drm/i915/panel: setup pwm backlight based on connector type
  drm/i915/bios: hide away VBT specific things in a private bios header

 drivers/gpu/drm/i915/i915_drv.h                    |    6 +-
 drivers/gpu/drm/i915/intel_bios.c                  |  156 ++-
 drivers/gpu/drm/i915/intel_bios.h                  | 1226 ++++----------------
 .../i915/{intel_bios.h => intel_bios_private.h}    |  230 +---
 drivers/gpu/drm/i915/intel_dp.c                    |   21 +-
 drivers/gpu/drm/i915/intel_dsi.c                   |   23 +-
 drivers/gpu/drm/i915/intel_lvds.c                  |   53 +-
 drivers/gpu/drm/i915/intel_panel.c                 |    4 +-
 drivers/gpu/drm/i915/intel_tv.c                    |   43 +-
 9 files changed, 438 insertions(+), 1324 deletions(-)
 rewrite drivers/gpu/drm/i915/intel_bios.h (76%)
 rename drivers/gpu/drm/i915/{intel_bios.h => intel_bios_private.h} (81%)

-- 
2.1.4



More information about the Intel-gfx mailing list