[Intel-gfx] [PATCH 03/11] drm/i915: Rename vma->*_list to *_link for consistency
chris at chris-wilson.co.uk
Thu Dec 17 03:24:34 PST 2015
On Thu, Dec 17, 2015 at 11:14:54AM +0000, Tvrtko Ursulin wrote:
> On 14/12/15 11:36, Chris Wilson wrote:
> >Elsewhere we have adopted the convention of using '_link' to denote
> >elements in the list (and '_list' for the actual list_head itself), and
> >that the name should indicate which list the link belongs to (and
> >preferrably not just where the link is being stored).
> >s/vma_link/obj_link/ (we iterate over obj->vma_list)
> >s/mm_list/vm_link/ (we iterate over vm->[in]active_list)
> A little bit of pain for the established muscle memory but I think
> good in general. Assuming you compile tested it:
> Reviewed-by: Tvrtko Ursulin <tvrtko.ursulin at intel.com>
> Btw perhaps rename the link in i915_gem_active to request_link so
> that the good initiative is not questioned. :)
I think I have:
There's still a drm_i915_gem_request.client_list to be fixed up, but I
can do that when I show off a scary patch to do lock-free client tracking.
I've read LWN today, my brian is mush. But at least I learnt about the
term lock-free locking.
Chris Wilson, Intel Open Source Technology Centre
More information about the Intel-gfx