[Intel-gfx] [PATCH v2 1/2] mm: Export nr_swap_pages
akpm at linux-foundation.org
Wed Dec 23 14:26:11 PST 2015
On Wed, 23 Dec 2015 17:04:27 -0500 Johannes Weiner <hannes at cmpxchg.org> wrote:
> On Thu, Dec 10, 2015 at 10:32:42AM +0100, Daniel Vetter wrote:
> > On Fri, Dec 04, 2015 at 11:09:52AM -0500, Johannes Weiner wrote:
> > > On Fri, Dec 04, 2015 at 03:58:53PM +0000, Chris Wilson wrote:
> > > > Some modules, like i915.ko, use swappable objects and may try to swap
> > > > them out under memory pressure (via the shrinker). Before doing so, they
> > > > want to check using get_nr_swap_pages() to see if any swap space is
> > > > available as otherwise they will waste time purging the object from the
> > > > device without recovering any memory for the system. This requires the
> > > > nr_swap_pages counter to be exported to the modules.
> > > >
> > > > Signed-off-by: Chris Wilson <chris at chris-wilson.co.uk>
> > > > Cc: "Goel, Akash" <akash.goel at intel.com>
> > > > Cc: Johannes Weiner <hannes at cmpxchg.org>
> > > > Cc: linux-mm at kvack.org
> > >
> > > Acked-by: Johannes Weiner <hannes at cmpxchg.org>
> > Ack for merging this through drm-intel trees for 4.5? I'm a bit unclear
> > who's ack I need for that for linux-mm topics ...
> Andrew would be the -mm maintainer. CC'd.
yup, please go ahead and merge that via the DRM tree.
nr_swap_pages is a crappy name. That means "number of pages in swap",
which isn't the case. Something like "swap_pages_available" would be
And your swap_available() isn't good either ;) It can mean "is any swap
online" or "what is the amount of free swap space (in unknown units!)".
I'd call it "swap_is_full()" and put a ! in the caller. But it's
hardly important for a wee little static helper.
More information about the Intel-gfx