[Intel-gfx] [PATCH 0/4] drm/i915: improve the RPM device suspended assert
Imre Deak
imre.deak at intel.com
Mon Nov 9 10:20:07 PST 2015
Motivated by the discussions with Chris about imrpoving our RPM ref
get/put logic and seeing that we are still missing RPM refs from
places I improved a bit the assert that checks if the device is powered
on while we are accessing the HW. This produced at least one additional
assert on the atomic commit path, so I think it's useful.
This is based on Patrik's DC rework patches [1], but just to avoid merge
conflicts, functionally it doesn't depend on that.
Tested on SKL.
[1]
http://lists.freedesktop.org/archives/intel-gfx/2015-November/079758.html
Imre Deak (4):
drm/i915: export assert_device_not_suspended
drm/i915: use assert_device_not_suspended instead of opencoding it
drm/i915: make assert_device_not_suspended more precise
drm/i915: add assert_device_not_suspended to GGTT PTE updaters
drivers/gpu/drm/i915/i915_drv.c | 5 +++++
drivers/gpu/drm/i915/i915_drv.h | 5 +++++
drivers/gpu/drm/i915/i915_gem_gtt.c | 8 ++++++++
drivers/gpu/drm/i915/intel_drv.h | 2 ++
drivers/gpu/drm/i915/intel_runtime_pm.c | 26 ++++++++++++++++++++------
drivers/gpu/drm/i915/intel_uncore.c | 9 +--------
6 files changed, 41 insertions(+), 14 deletions(-)
--
2.5.0
More information about the Intel-gfx
mailing list