[Intel-gfx] [maintainer-tools RFC PATCH 00/17] dim: function based subcommand handling

Jani Nikula jani.nikula at intel.com
Tue Jan 26 06:32:13 PST 2016

I propose to change the dim tool to handle subcommands via functions
matching the subcommand. Each 'dim sub-command' would be handled by a
function named dim_sub_command. Only functions handling subcommands
would have the dim_ prefix.

Patches 1-11 are mostly renames to follow the proposed naming scheme.

Patch 12 separates handling of aliases to an independent piece of code.

Patch 13 actually starts handling subcommands via the defined
functions. Some of the benefits of the approach are covered in the
commit message.

Patches 14-17 starts abstracting subcommand cases to functions. This is
mostly mechanical work, and I didn't bother with it until I get an ack
on the approach.

I've only tested this lightly, thus RFC.


Jani Nikula (17):
  dim: rename dim_push to dim_push_branch
  dim: rename dim_apply to dim_apply_branch
  dim: rename dim_co to dim_checkout
  dim: rename dim_shell_checkpatch to shell_checkpatch
  dim: rename dim_checkpatch to checkpatch_commit
  dim: rename dim_checkrange to dim_checkpatch
  dim: rename setup_dim to dim_setup
  dim: rename create_workdir to dim_create_workdir
  dim: rename update_nightly to dim_rebuild_nightly
  dim: rename magic_patch to dim_magic_patch
  dim: move dim_pull_request parameter check to the function
  dim: separate handling of aliases
  dim: handle subcommands through functions
  dim: abstract dim_nightly_forget
  dim: abstract dim_update_branches
  dim: abstract dim_for_each_workdirs
  dim: abstract dim_push_*

 dim | 239 ++++++++++++++++++++++++++++++++++++--------------------------------
 1 file changed, 128 insertions(+), 111 deletions(-)


More information about the Intel-gfx mailing list