[Intel-gfx] [PATCH 2/2] drm/i915: Refer to GGTT VM consistently

Chris Wilson chris at chris-wilson.co.uk
Wed Mar 23 13:25:45 UTC 2016

On Wed, Mar 23, 2016 at 03:00:23PM +0200, Joonas Lahtinen wrote:
> Refer to the GGTT VM consistently as "ggtt_vm" instead of just "ggtt",
> "vm" or indirectly through other variables like "dev_priv->ggtt.base"
> to avoid confusion with the i915_ggtt object itself and PPGTT VMs.

On the one hand, yes it seems more fitting to call it ggtt_vm. On the
other, we've been pretty consistent in calling the address space ggtt!
And I like the look of ggtt far more than ggtt_vm. Killing off more
mixed dev_priv->ggtt.base and ggtt pointer usage is definitely good
though. But I'm ambivalent about the whole.

Chris Wilson, Intel Open Source Technology Centre

More information about the Intel-gfx mailing list