[Intel-gfx] [PATCH RESEND 2/2] drm/i915: don't mix bitwise and logical operations for has_snoop
Tvrtko Ursulin
tvrtko.ursulin at linux.intel.com
Fri May 13 15:08:09 UTC 2016
On 13/05/16 15:04, Jani Nikula wrote:
> Also make the code more readable.
>
> Signed-off-by: Jani Nikula <jani.nikula at intel.com>
> ---
> drivers/gpu/drm/i915/i915_dma.c | 6 ++++--
> 1 file changed, 4 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/gpu/drm/i915/i915_dma.c b/drivers/gpu/drm/i915/i915_dma.c
> index 547100fa3122..a8c79f6512a4 100644
> --- a/drivers/gpu/drm/i915/i915_dma.c
> +++ b/drivers/gpu/drm/i915/i915_dma.c
> @@ -954,9 +954,11 @@ static void intel_device_info_runtime_init(struct drm_device *dev)
> else if (INTEL_INFO(dev)->gen >= 9)
> gen9_sseu_info_init(dev);
>
> - /* Snooping is broken on BXT A stepping. */
> info->has_snoop = !info->has_llc;
> - info->has_snoop &= !IS_BXT_REVID(dev, 0, BXT_REVID_A1);
> +
> + /* Snooping is broken on BXT A stepping. */
> + if (IS_BXT_REVID(dev, 0, BXT_REVID_A1))
> + info->has_snoop = false;
>
> DRM_DEBUG_DRIVER("slice total: %u\n", info->slice_total);
> DRM_DEBUG_DRIVER("subslice total: %u\n", info->subslice_total);
>
Yeah that is more readable.
Reviewed-by: Tvrtko Ursulin <tvrtko.ursulin at intel.com>
Regards,
Tvrtko
More information about the Intel-gfx
mailing list