[Intel-gfx] [PATCH i-g-t v5 0/7] kms_flip_event_leak and kms_vblank fixes for

robert.foss at collabora.com robert.foss at collabora.com
Mon May 16 13:38:25 UTC 2016


From: Robert Foss <robert.foss at collabora.com>

In addition to the changes made in v4, danvet suggested that the argument for
the (newly renamed) helper function kmstest_get_vbl_flag should be changed.

I investigated it and found that all of the places where the helper function
currently is used, would require more of a rework with changed arguments than
with unchanged arguments, so I decided to not change the arguments.

Changes since v1:
- kms_vblank: Removed un-used members of data_t struct.
- Rename plane_counter to n_planes.
- Removed un-needed handling CURSOR plane location.
- Added names for additional planes in update kmstest_plane_name.

Changes since v2:
- Rebased onto trunk which already contains kms_flip_event_leak changes.

Changes since v3:
- kms_vblank.c: Removed drm_fd from data_t, to decrease the number of
unrelated changes in the patch.
- kms_vblank.c: Changed "int valid_tests" to "unsigned valid_tests".
- kms_vblank.c: Changed crtc_id_flag/crtc_id_to_flag to
pipe_id_flag/pipe_id_to_flag.
- kms_vblank.c: Changed to "vbl.request.type |= crtc_id_flag;".
- kms_vblank.c: Moved crtc_id_to_flag to igt_kms.c.
- kms_vblank.c: Renamed crtc_id_to_flag to pipe_id_to_vbl_flag.
- kms_flip.c: Changed test busy_mode boolean into mode_busy bitfield in struct
data.
- igt_kms.h: Moved IGT_PLANE_CURSOR position comment.

Changes since v4:
- kms_vblank.c: Removed whitespace at end of file.
- igt_kms: Changed name of helper function to kmstest_get_vbl_flag
- igt_kms: Changed kmstest_get_vbl_flag to not set DRM_VBLANK_RELATIVE flag

Robert Foss (7):
  lib/igt_kms: Add support for up to 10 planes.
  lib/igt_kms: Fix plane counting in igt_display_init.
  lib/igt_kms: Switch to verbose assert.
  lib/igt_kms: Added pipe_id_to_vbl_flag() to igt_kms.
  kms_vblank: Switch from using crtc0 statically to explicitly setting
    mode.
  igt_kms: Change igt_wait_for_vblank to use helper function.
  kms_flip: Change __wait_for_vblank to use helper function.

 lib/igt_kms.c      |  36 ++++++++++--
 lib/igt_kms.h      |   9 ++-
 tests/kms_flip.c   |   8 +--
 tests/kms_vblank.c | 161 ++++++++++++++++++++++++++++++++++++++++++++---------
 4 files changed, 179 insertions(+), 35 deletions(-)

-- 
2.7.4



More information about the Intel-gfx mailing list