[Intel-gfx] [PATCH v2 0/5] GuC code reorganization
Arkadiusz Hiler
arkadiusz.hiler at intel.com
Thu Nov 24 16:13:18 UTC 2016
With HuC being imminent we could benefit from some code reorganization.
There will be more uC than just GuC so we should name files accordingly.
There is also need to use host2guc_*() family of functions, which are currently
limited to submission only.
In effect host2guc and guc2host entities were renamed and moved around.
v2: host2guc and guc2host renaming, init mutex in intel_uc_init()
Arkadiusz Hiler (5):
drm/i915: Rename intel_guc.h to intel_uc.h
drm/i915/guc: Drop guc2host/host2guc from names
drm/i915/guc: Move guc_{send,recv}() to intel_uc.c
drm/i915/guc: Init send_mutex in intel_uc_init()
drm/i915/guc: Remove spurious include
drivers/gpu/drm/i915/Makefile | 3 +-
drivers/gpu/drm/i915/i915_drv.c | 1 +
drivers/gpu/drm/i915/i915_drv.h | 2 +-
drivers/gpu/drm/i915/i915_guc_reg.h | 4 +-
drivers/gpu/drm/i915/i915_guc_submission.c | 158 ++++-------------------
drivers/gpu/drm/i915/i915_irq.c | 4 +-
drivers/gpu/drm/i915/intel_guc_fwif.h | 49 +++----
drivers/gpu/drm/i915/intel_guc_loader.c | 2 +-
drivers/gpu/drm/i915/intel_uc.c | 143 ++++++++++++++++++++
drivers/gpu/drm/i915/{intel_guc.h => intel_uc.h} | 20 ++-
10 files changed, 215 insertions(+), 171 deletions(-)
create mode 100644 drivers/gpu/drm/i915/intel_uc.c
rename drivers/gpu/drm/i915/{intel_guc.h => intel_uc.h} (91%)
--
2.7.4
More information about the Intel-gfx
mailing list