[Intel-gfx] [PATCH] kernel/cpu: Distinct name for cpu_hotplug.dep_map

Joonas Lahtinen joonas.lahtinen at linux.intel.com
Wed Oct 12 10:18:56 UTC 2016


Hi Linus/Andrew,

This patch has been waiting for feedback or merging for ~8 months now.
It was posted to linux-kernel at vger.kernel.org initially and got an
immediate Acked-by. After no other feedback, I revised the assumed
maintainers and still no reactions. Next I changed over to
trivial at kernel.org and it was reviewed by Chris in the meanwhile,
but still no other feedback or merge (now 2 months).

I don't think sending the patch around endlessly is very productive,
or hammering same mailing lists/people repeatedly for that matter. So
I'd like to hear what's the correct channel for getting the patch in?

It has been dragged in a i915 testing branch to make CI lockdep splats
more readable.

Regards, Joonas
--------------------8<---------------------------
Use distinctive name for cpu_hotplug.dep_map to avoid the actual
cpu_hotplug.lock appearing as cpu_hotplug.lock#2 in lockdep splats.

Cc: Ingo Molnar <mingo at kernel.org>
Cc: Peter Zijlstra <peterz at infradead.org>
Cc: Gautham R. Shenoy <ego at linux.vnet.ibm.com>
Cc: intel-gfx at lists.freedesktop.org
Cc: trivial at kernel.org
Acked-by: Gautham R. Shenoy <ego at linux.vnet.ibm.com>
Reviewed-by: Chris Wilson <chris at chris-wilson.co.uk>
Signed-off-by: Joonas Lahtinen <joonas.lahtinen at linux.intel.com>
---
 kernel/cpu.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/kernel/cpu.c b/kernel/cpu.c
index 5df20d6..29de1a9 100644
--- a/kernel/cpu.c
+++ b/kernel/cpu.c
@@ -228,7 +228,7 @@ static struct {
 	.wq = __WAIT_QUEUE_HEAD_INITIALIZER(cpu_hotplug.wq),
 	.lock = __MUTEX_INITIALIZER(cpu_hotplug.lock),
 #ifdef CONFIG_DEBUG_LOCK_ALLOC
-	.dep_map = {.name = "cpu_hotplug.lock" },
+	.dep_map = STATIC_LOCKDEP_MAP_INIT("cpu_hotplug.dep_map", &cpu_hotplug.dep_map),
 #endif
 };
 
-- 
2.7.4



More information about the Intel-gfx mailing list