[Intel-gfx] [RFC 2/4] drm/i915: Use macro in place of open-coded for_each_universal_plane loop
Paulo Zanoni
paulo.r.zanoni at intel.com
Fri Oct 28 18:17:46 UTC 2016
Em Qua, 2016-10-26 às 15:51 -0700, Matt Roper escreveu:
> This was the only use of (misleadingly-named) intel_num_planes()
> function, so we can remove it as well.
This one has a trivial conflict with Maarten's series. Same comment as
p1 regarding merging.
Reviewed-by: Paulo Zanoni <paulo.r.zanoni at intel.com>
>
> Signed-off-by: Matt Roper <matthew.d.roper at intel.com>
> ---
> drivers/gpu/drm/i915/intel_drv.h | 9 ---------
> drivers/gpu/drm/i915/intel_pm.c | 2 +-
> 2 files changed, 1 insertion(+), 10 deletions(-)
>
> diff --git a/drivers/gpu/drm/i915/intel_drv.h
> b/drivers/gpu/drm/i915/intel_drv.h
> index c2f3863..c31fddd 100644
> --- a/drivers/gpu/drm/i915/intel_drv.h
> +++ b/drivers/gpu/drm/i915/intel_drv.h
> @@ -1108,15 +1108,6 @@ hdmi_to_dig_port(struct intel_hdmi
> *intel_hdmi)
> return container_of(intel_hdmi, struct intel_digital_port,
> hdmi);
> }
>
> -/*
> - * Returns the number of planes for this pipe, ie the number of
> sprites + 1
> - * (primary plane). This doesn't count the cursor plane then.
> - */
> -static inline unsigned int intel_num_planes(struct intel_crtc *crtc)
> -{
> - return INTEL_INFO(crtc->base.dev)->num_sprites[crtc->pipe] +
> 1;
> -}
> -
> /* intel_fifo_underrun.c */
> bool intel_set_cpu_fifo_underrun_reporting(struct drm_i915_private
> *dev_priv,
> enum pipe pipe, bool
> enable);
> diff --git a/drivers/gpu/drm/i915/intel_pm.c
> b/drivers/gpu/drm/i915/intel_pm.c
> index 58d3ba0..6f19e60 100644
> --- a/drivers/gpu/drm/i915/intel_pm.c
> +++ b/drivers/gpu/drm/i915/intel_pm.c
> @@ -4232,7 +4232,7 @@ static void skl_update_wm(struct drm_crtc
> *crtc)
> if (crtc->state->active_changed) {
> int plane;
>
> - for (plane = 0; plane <
> intel_num_planes(intel_crtc); plane++)
> + for_each_universal_plane(dev_priv, pipe, plane)
> skl_write_plane_wm(intel_crtc, &pipe_wm-
> >planes[plane],
> &results->ddb, plane);
>
More information about the Intel-gfx
mailing list