[Intel-gfx] [PATCH 03/38] drm/i915: Always use the GTT for error capture

Joonas Lahtinen joonas.lahtinen at linux.intel.com
Wed Sep 21 07:24:27 UTC 2016


On ti, 2016-09-20 at 09:29 +0100, Chris Wilson wrote: 
> +	/* Reserve a mappable slot for our lockless error capture */
> +	ret = drm_mm_insert_node_in_range_generic(&ggtt->base.mm,
> +						  &ggtt->gpu_error,

'error_page' would arguably be better name, or pretty much anything but
'gpu_error'.

> @@ -2788,6 +2802,9 @@ void i915_ggtt_cleanup_hw(struct drm_i915_private *dev_priv)
>  
>  	i915_gem_cleanup_stolen(&dev_priv->drm);
>  
> +	if (drm_mm_node_allocated(&ggtt->gpu_error))
> +		drm_mm_remove_node(&ggtt->gpu_error);
> +

Is there really a legit case of this being called twice? Or be called
without the init?

With the variable name fixed;

Reviewed-by: Joonas Lahtinen <joonas.lahtinen at linux.intel.com>

Regards, Joonas
-- 
Joonas Lahtinen
Open Source Technology Center
Intel Corporation


More information about the Intel-gfx mailing list