[Intel-gfx] [PULL] drm-misc-next-fixes
Sean Paul
seanpaul at chromium.org
Fri Apr 21 18:10:24 UTC 2017
On Thu, Apr 20, 2017 at 11:50:02PM +0200, Daniel Vetter wrote:
> On Thu, Apr 20, 2017 at 10:11 PM, Sean Paul <seanpaul at chromium.org> wrote:
> > Hi Dave,
> > A few fixes for you to pick up. The driver changes are trivial, and the
> > maintainer change was necessitated by the sti fix. The headliner here is the
> > dma_buf_ops rename, since it touches so many drivers. Everything looks sane and
> > builds with that change, so it shouldn't cause problems.
> >
> >
> > drm-misc-next-fixes-2017-04-20:
> >
> > Core changes:
> > - Maintain sti via drm-misc (Vincent)
> > - Rename dma_buf_ops->kmap_* to avoid naming collision (Logan)
>
> This one touches v4l and ion and is acked by the corresponding
> maintainers (but Sumit forgot to record that when applying the patch,
> and Sean didn't highlight it in the summary).
>
> Sean, should we augment the template that cross-subsystem stuff
> (outside of what's on-topic for drm-misc) needs to be highlighted
> specifically in the pull summary?
Yeah, I think that's reasonable. I'd like to think that I would have done a
better job highlighting this had it been a standard header. Going forward, I'll
add UABI and cross-sub headers to force myself to be more careful :)
>
> Off for vacation for real now.
Enjoy!
Sean
>
> Cheers, Daniel
>
> >
> > Driver changes:
> > - Fix UHD displays on stih407 (Vincent)
> > - Fix uninitialized var return in atmel-hlcdc (Dan)
> >
> > Take care, Sean
> >
> >
> > The following changes since commit 8cb68c83ab99a474ae847602f0c514d0fe17cc82:
> >
> > drm: Fix get_property logic fumble (2017-04-12 18:11:32 +0200)
> >
> > are available in the git repository at:
> >
> > git://anongit.freedesktop.org/git/drm-misc tags/drm-misc-next-fixes-2017-04-20
> >
> > for you to fetch changes up to f9b67f0014cba18f1aabb6fa9272335a043eb6fd:
> >
> > dma-buf: Rename dma-ops to prevent conflict with kunmap_atomic macro (2017-04-20 13:47:46 +0530)
> >
> > ----------------------------------------------------------------
> > drm-misc-next-fixes-2017-04-20
> >
> > Core changes:
> > - Maintain sti via drm-misc (Vincent)
> > - Rename dma_buf_ops->kmap_* to avoid naming collision (Logan)
> >
> > Driver changes:
> > - Fix UHD displays on stih407 (Vincent)
> > - Fix uninitialized var return in atmel-hlcdc (Dan)
> >
> > ----------------------------------------------------------------
> > Dan Carpenter (1):
> > drm: atmel-hlcdc: Uninitialized return in atmel_hlcdc_create_outputs()
> >
> > Logan Gunthorpe (1):
> > dma-buf: Rename dma-ops to prevent conflict with kunmap_atomic macro
> >
> > Vincent Abriou (2):
> > MAINTAINERS: add drm/sti driver into drm-misc
> > drm/sti: fix GDP size to support up to UHD resolution
> >
> > MAINTAINERS | 2 +-
> > drivers/dma-buf/dma-buf.c | 16 ++++++++--------
> > drivers/gpu/drm/armada/armada_gem.c | 8 ++++----
> > drivers/gpu/drm/atmel-hlcdc/atmel_hlcdc_output.c | 5 ++---
> > drivers/gpu/drm/drm_prime.c | 8 ++++----
> > drivers/gpu/drm/i915/i915_gem_dmabuf.c | 8 ++++----
> > drivers/gpu/drm/i915/selftests/mock_dmabuf.c | 8 ++++----
> > drivers/gpu/drm/omapdrm/omap_gem_dmabuf.c | 8 ++++----
> > drivers/gpu/drm/sti/sti_gdp.c | 12 +++++++-----
> > drivers/gpu/drm/tegra/gem.c | 8 ++++----
> > drivers/gpu/drm/udl/udl_dmabuf.c | 8 ++++----
> > drivers/gpu/drm/vmwgfx/vmwgfx_prime.c | 8 ++++----
> > drivers/media/v4l2-core/videobuf2-dma-contig.c | 4 ++--
> > drivers/media/v4l2-core/videobuf2-dma-sg.c | 4 ++--
> > drivers/media/v4l2-core/videobuf2-vmalloc.c | 4 ++--
> > drivers/staging/android/ion/ion.c | 8 ++++----
> > include/linux/dma-buf.h | 22 +++++++++++-----------
> > 17 files changed, 71 insertions(+), 70 deletions(-)
> >
> > --
> > Sean Paul, Software Engineer, Google / Chromium OS
>
>
>
> --
> Daniel Vetter
> Software Engineer, Intel Corporation
> +41 (0) 79 365 57 48 - http://blog.ffwll.ch
--
Sean Paul, Software Engineer, Google / Chromium OS
More information about the Intel-gfx
mailing list