[Intel-gfx] [PATCH] drm/i915: KW fix in intel_dsi_dcs_backlight.c

Jani Nikula jani.nikula at linux.intel.com
Thu Aug 3 12:39:48 UTC 2017


On Thu, 03 Aug 2017, "Balasubramaniam, Hari Chand" <hari.chand.balasubramaniam at intel.com> wrote:
> variable 'data' might be used uninitialized in this function.
>
> Thus, adding NULL initialized to 'data' variable.
>
> SQUASHME! - This patch should be squashed into following existing patch

The upstream commit has been merged and released in v4.8, kind of hard
to squash! And the commit is in fact

commit 90198355b83c79e2158ec591085858b191f08502
Author: Jani Nikula <jani.nikula at intel.com>
Date:   Tue Apr 26 16:14:25 2016 +0300

    drm/i915/dsi: Add DCS control for Panel PWM

Please update the commit message to reflect upstream. You'll also need

Fixes: 90198355b83c ("drm/i915/dsi: Add DCS control for Panel PWM")
Cc: Jani Nikula <jani.nikula at intel.com>
Cc: Daniel Vetter <daniel.vetter at intel.com>
Cc: Yetunde Adebisi <yetundex.adebisi at intel.com>
Cc: Deepak M <m.deepak at intel.com>
Cc: Jani Nikula <jani.nikula at linux.intel.com>


BR,
Jani.


>
>         Author: Paulo Zanoni <paulo.r.zanoni at intel.com>
>         Author: Deepak M <m.deepak at intel.com>
> 	Date:   Wed Apr 19 15:49:02 2017 +0800
>
>     	  drm/i915/dsi: Add DCS control for Panel PWM
>
>     	  If the source of the backlight PWM is from the
>     	  panel then the PWM can be controlled by DCS
>     	  command, this patch adds the support to
>     	  enable/disbale panel PWM, control backlight level
>     	  etc...
>
>     	  v2: Moving the CABC bkl functions to new file.(Jani)
>
>     	  v3: Rebase
>
>     	  v4: Rebase
>
>     	  v5: Use mipi_dsi_dcs_write() instead of mipi_dsi_dcs_write_buffer() (Jani)
>               Move DCS macro`s to include/video/mipi_display.h (Jani)
>
>     	  v6: Rename the file to intel_dsi_panel_pwm.c
>               Removing the CABC operations
>
>     	  v7 by Jani: renames, rebases, etc.
>
>     	  v8 by Jani: s/INTEL_BACKLIGHT_CABC/INTEL_BACKLIGHT_DSI_DCS/
>
>     	  v9 by Jani: rename init function to intel_dsi_dcs_init_backlight_funcs
>
>     	  Cc: Jani Nikula <jani.nikula at intel.com>
>     	  Cc: Daniel Vetter <daniel.vetter at intel.com>
>     	  Cc: Yetunde Adebisi <yetundex.adebisi at intel.com>
>     	  Signed-off-by: Deepak M <m.deepak at intel.com>
>     	  Reviewed-by: Yetunde Adebisi <yetundex.adebisi at intel.com>
>     	  Signed-off-by: Jani Nikula <jani.nikula at intel.com>
>     	  Link: http://patchwork.freedesktop.org/patch/msgid/71238a4b14b8c3a6c04070c789f09f1b4bc00a15.1461676337.git.jani.nikula@intel.com
>     	  (cherry picked from commit 90198355b83c79e2158ec591085858b191f08502)
>     	  Signed-off-by: Matt Roper <matthew.d.roper at intel.com>
>
>     	  Change-Id: Icab0769c56fbb59f24d35fcb0a14c21a858bf8ac
>
> Change-Id: Ib16bdda6c1950efddf66e31ab3172a2a17b09bc9
> Signed-off-by: Balasubramaniam, Hari Chand <hari.chand.balasubramaniam at intel.com>
> ---
>  drivers/gpu/drm/i915/intel_dsi_dcs_backlight.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/gpu/drm/i915/intel_dsi_dcs_backlight.c b/drivers/gpu/drm/i915/intel_dsi_dcs_backlight.c
> index ac7c602..eec4585 100644
> --- a/drivers/gpu/drm/i915/intel_dsi_dcs_backlight.c
> +++ b/drivers/gpu/drm/i915/intel_dsi_dcs_backlight.c
> @@ -46,7 +46,7 @@ static u32 dcs_get_backlight(struct intel_connector *connector)
>  	struct intel_encoder *encoder = connector->encoder;
>  	struct intel_dsi *intel_dsi = enc_to_intel_dsi(&encoder->base);
>  	struct mipi_dsi_device *dsi_device;
> -	u8 data;
> +	u8 data = 0;
>  	enum port port;
>  
>  	/* FIXME: Need to take care of 16 bit brightness level */

-- 
Jani Nikula, Intel Open Source Technology Center


More information about the Intel-gfx mailing list