[Intel-gfx] [PATCH 1/8] drm/i915/guc: Make the GuC fw loading helper functions general
arkadiusz.hiler at intel.com
Thu Jan 5 12:25:24 UTC 2017
On Wed, Jan 04, 2017 at 06:55:48AM -0800, Anusha Srivatsa wrote:
> From: Peter Antoine <peter.antoine at intel.com>
> Rename some of the GuC fw loading code to make them more general. We
> will utilise them for HuC loading as well.
> Struct intel_guc_fw is renamed to intel_uc_fw. Prefix of tts members,
> such as 'guc' or 'guc_fw' either is renamed to 'uc' or removed for
> same purpose.
> v2: rebased on top of nightly.
> reapplied the search/replace as upstream code as changed.
> v3: rebased again on drm-nightly.
> v4: removed G from messages in shared fw fetch function.
> v5: rebased.
> v7: rebased.
> v8: rebased.
> v9: rebased.
> v10: rebased.
> v11: rebased.
> v12: rebased on top of drm-tip
> v13: rebased.Updated dev to dev_priv in intel_guc_setup(), guc_fw_getch()
> and intel_guc_init().
> v14: rebased. Remove uint32_t fw_type to patch 2. Add INTEL_ prefix for
> fields in enum intel_uc_fw_status. Remove uc_dev field since its never
> used.Rename uc_fw to just fw and guc_fw to fw to avoid redundency.
> v15: rebased. Remove sections of code that were commented and no longer
> v16: rebased. Remove uc_fw_ prefix from path and obj fields
> in intel_uc_fw struct as suggested by Michal.
> Cc: Michal Wajdeczko <michal.wajdeczko at intel.com>
> Cc: Arkadiusz Hiler <arkadiusz.hiler at intel.com>
> Signed-off-by: Anusha Srivatsa <anusha.srivatsa at intel.com>
> Signed-off-by: Alex Dai <yu.dai at intel.com>
> Signed-off-by: Peter Antoine <peter.antoine at intel.com>
Reviewed-by: Arkadiusz Hiler <arkadiusz.hiler at intel.com>
> drivers/gpu/drm/i915/i915_debugfs.c | 12 +--
> drivers/gpu/drm/i915/i915_guc_submission.c | 4 +-
> drivers/gpu/drm/i915/intel_guc_loader.c | 156 ++++++++++++++---------------
> drivers/gpu/drm/i915/intel_uc.h | 36 +++----
> 4 files changed, 104 insertions(+), 104 deletions(-)
More information about the Intel-gfx