[Intel-gfx] [PATCH] drm/i915: Use IS_GEN9 and IS_LP to put Skylake and Kabylake in the same bucket.
jani.nikula at intel.com
Mon Jan 23 08:07:46 UTC 2017
On Mon, 23 Jan 2017, "Conselvan De Oliveira, Ander" <ander.conselvan.de.oliveira at intel.com> wrote:
> On Fri, 2017-01-20 at 08:22 -0800, Rodrigo Vivi wrote:
>> On Thu, Jan 19, 2017 at 10:56 PM, Jani Nikula <jani.nikula at intel.com> wrote:
>> > On Fri, 20 Jan 2017, Anusha Srivatsa <anusha.srivatsa at intel.com> wrote:
>> > >
>> > > With GLK was introduced IS_LP.
>> > > With this, we can use IS_GEN9 and IS_LP to put Skylake
>> > > and Kabylake in the same bucket. The main intention is
>> > > to simplify the if and else statements that gets added
>> > > for every new platform.
>> > >
>> > > This approach proposes the idea to create a common bucket
>> > > to put multiple platforms (SKL and KBL in this case)
>> > > together. Another approach would be to introduce IS_GEN9_BC
>> > > as suggested by Rodrigo, where _BC stands for Big Core.
>> > I think we need to come up with an alias like IS_GEN9_BC(), although I'm
>> > not convinced about that paraticular name. The current (FOO || BAR) for
>> > specific FOO and BAR is *much* faster to read than the slightly
>> > confusing (GROUP && !SUBGROUP).
>> I don't have a strong opinion on this one except that I believe we
>> need to group somehow.
>> But I didn't try to merge the reviewed is_gen9_bc because someone
>> raised concerns on irc like naking it...
>> maybe Mika or Marteen, I can't remember...
>> Ander, do you remember who complained that day on irc?
> I think it was Joonas. He didn't like my suggestion of _HP for high power. To be
> honest, I don't like it either. :)
>> I remember Tvrtko was the one in favor of using !is_lp...
> IS_GEN9_NP for not-low power. Or even normal power.
>> I agree _BC (Big Core) is not a good name... but I couldn't come with
>> something better. :(
>> So either way works for me as long as we bucket is somehow...
>> So, comments?
> I don't know either. I think there's value in the change and I
> wouldn't mind if it is called _BC, and that's why that patch has my
> R-b. Wouldn't it be easier to do sed 's/IS_GEN9_BC/something else/' if
> some one has a great moment of inspiration?
Ack on that.
Jani Nikula, Intel Open Source Technology Center
More information about the Intel-gfx