[Intel-gfx] [PATCH 0/7] drm/i915/dsi: stop using drm_panel, refactor
Jani Nikula
jani.nikula at intel.com
Mon Mar 6 14:31:23 UTC 2017
This is pretty natural continuation to what Hans started. We haven't
made use of the drm_panel framework much at all, and there's no need in
sight, really. It was good for ensuring a certain amount of separation
between the core and the VBT stuff. Let's keep things that way, but
without the interface.
BR,
Jani.
Jani Nikula (7):
drm/i915/dsi: remove support for more than one panel driver
drm/i915/dsi: call vbt_panel_get_modes directly instead of via
drm_panel
drm/i915/dsi: stop using the drm_panel framework completely
drm/i915/dsi: rename intel_dsi_exec_vbt_sequence to
intel_dsi_vbt_exec_sequence
drm/i915/dsi: rename intel_dsi_pre_disable to intel_dsi_disable
drm/i915/dsi: rename intel_dsi_panel_vbt.c to intel_dsi_vbt.c
drm/i915/dsi: arrange intel_dsi.h according to relevant files
drivers/gpu/drm/i915/Makefile | 2 +-
drivers/gpu/drm/i915/intel_dsi.c | 76 ++++++++--------------
drivers/gpu/drm/i915/intel_dsi.h | 14 ++--
.../{intel_dsi_panel_vbt.c => intel_dsi_vbt.c} | 46 +++----------
4 files changed, 43 insertions(+), 95 deletions(-)
rename drivers/gpu/drm/i915/{intel_dsi_panel_vbt.c => intel_dsi_vbt.c} (95%)
--
2.1.4
More information about the Intel-gfx
mailing list