[Intel-gfx] [PATCH 6/9] drm/i915: Split execlist priority queue into rbtree + linked list

Tvrtko Ursulin tvrtko.ursulin at linux.intel.com
Fri May 5 14:24:14 UTC 2017


On 05/05/2017 15:04, Chris Wilson wrote:
> On Fri, May 05, 2017 at 02:50:46PM +0100, Tvrtko Ursulin wrote:
>>
>> On 03/05/2017 12:37, Chris Wilson wrote:
>>
>> [snip]
>>
>>> +#include <linux/list.h>
>>> +
>>> +static inline void __list_del_many(struct list_head *head,
>>> +				   struct list_head *first)
>>> +{
>>> +	head->next = first;
>>> +	first->prev = head;
>>> +}
>>
>> Btw it is similar to __list_cut_position, but without the second
>> list you don't need and deleting the first entry which you do not
>> want.
>>
>> So I am just thinking if consistent naming with the core function
>> would be beneficial like __list_cut_position_before/exclusive?
>
> It's not a cut, as in we don't create two seperate lists. It is more of
> splice with itself, though I did look at cut and wonder if it would
> magically eliminate the unwanted paths but no..
>
> Still favouring a list_del prefix. Once upon a time I just opencoded
> this, it's far easily than trying to work out a good name :)

It's not __list_del_many either since it does not unlink the ones in the 
middle. ;) Doesn't matter, as you say, it is quite hard to find the 
ideal name.

Regards,

Tvrtko


More information about the Intel-gfx mailing list