[Intel-gfx] [PATCH i-g-t 13/13] tests/gem_exec_nop: Rename signal() to fence_signal()

Arkadiusz Hiler arkadiusz.hiler at intel.com
Tue May 16 13:25:02 UTC 2017


Unfortunately <signal.h> is included through some obscure dependencies
when using bionic, so we have a name clash on signal().

Changed the test function name to fence_signal() to avoid this, but left
the test cases names unchanged.

Signed-off-by: Arkadiusz Hiler <arkadiusz.hiler at intel.com>
---
 tests/gem_exec_nop.c | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/tests/gem_exec_nop.c b/tests/gem_exec_nop.c
index d96f068..d61e120 100644
--- a/tests/gem_exec_nop.c
+++ b/tests/gem_exec_nop.c
@@ -517,9 +517,9 @@ static bool fence_wait(int fence)
 	return poll(&(struct pollfd){fence, POLLIN}, 1, -1) == 1;
 }
 
-static void signal(int fd, uint32_t handle,
-		   unsigned ring_id, const char *ring_name,
-		   int timeout)
+static void fence_signal(int fd, uint32_t handle,
+			 unsigned ring_id, const char *ring_name,
+			 int timeout)
 {
 #define NFENCES 512
 	struct drm_i915_gem_execbuffer2 execbuf;
@@ -659,11 +659,11 @@ igt_main
 		igt_subtest_f("%s", e->name)
 			single(device, handle, e->exec_id | e->flags, e->name);
 		igt_subtest_f("signal-%s", e->name)
-			signal(device, handle, e->exec_id | e->flags, e->name, 5);
+			fence_signal(device, handle, e->exec_id | e->flags, e->name, 5);
 	}
 
 	igt_subtest("signal-all")
-		signal(device, handle, -1, "all", 150);
+		fence_signal(device, handle, -1, "all", 150);
 
 	igt_subtest("series")
 		series(device, handle, 150);
-- 
2.9.3



More information about the Intel-gfx mailing list