[Intel-gfx] [PATCH v2 0/6] GuC submission functions/struct name/prototype update
Sagar Arun Kamble
sagar.a.kamble at intel.com
Thu Nov 16 09:53:49 UTC 2017
We want to have consistent function/structure/file naming and
function parameter semantics. Suggestion from Michal Wajdeczko about
using "genx_" prefix (or better _genx" suffix for all hw related
structures types, offsets), "i915_" prefix for driver entry calls and
"intel_" in all other seems to be the good scheme to go ahead.
Also we need to adhere to practise of passing drm_i915_private to
functions with "i915_" prefix and component structure to functions
with "intel_" prefix. This series updates GuC submission related code
with these changes.
With GuC submission being hardware interface for i915, we should name
those functions with prefix "intel_guc" and pass struct intel_guc as
parameter. Also i915_guc_client struct is kernel-hw interaction
structure hence rename that to intel_guc_client.
With these changes GuC submission source files are now named with
"intel_" prefix.
v2: Prepared two new patches to update tasklet naming and static GuC
submission functions. Addressed reviews.
Cc: Michal Wajdeczko <michal.wajdeczko at intel.com>
Cc: Michal Winiarski <michal.winiarski at intel.com>
Cc: Oscar Mateo <oscar.mateo at intel.com>
Cc: Daniele Ceraolo Spurio <daniele.ceraolospurio at intel.com>
Cc: Arkadiusz Hiler <arkadiusz.hiler at intel.com>
Cc: Chris Wilson <chris at chris-wilson.co.uk>
Cc: Tvrtko Ursulin <tvrtko.ursulin at intel.com>
Cc: Joonas Lahtinen <joonas.lahtinen at linux.intel.com>
Acked-by: Chris Wilson <chris at chris-wilson.co.uk>
Acked-by: Joonas Lahtinen <joonas.lahtinen at linux.intel.com>
Acked-by: Oscar Mateo <oscar.mateo at intel.com>
Sagar Arun Kamble (6):
drm/i915: Update execlists tasklet naming
drm/i915/guc: Update names of submission related static functions
drm/i915/guc: Update name and prototype of GuC submission interface
functions
drm/i915/guc: Rename i915_guc_client struct to intel_guc_client
drm/i915/guc: Rename i915_guc_submission.c|h to
intel_guc_submission.c|h
HAX enable GuC submission for CI
Documentation/gpu/i915.rst | 4 +-
drivers/gpu/drm/i915/Makefile | 6 +-
drivers/gpu/drm/i915/i915_debugfs.c | 6 +-
drivers/gpu/drm/i915/i915_gem.c | 10 +-
drivers/gpu/drm/i915/i915_gem_gtt.c | 8 +-
drivers/gpu/drm/i915/i915_guc_submission.c | 1466 --------------------------
drivers/gpu/drm/i915/i915_guc_submission.h | 80 --
drivers/gpu/drm/i915/i915_irq.c | 2 +-
drivers/gpu/drm/i915/i915_params.h | 4 +-
drivers/gpu/drm/i915/intel_engine_cs.c | 2 +-
drivers/gpu/drm/i915/intel_guc.c | 2 +-
drivers/gpu/drm/i915/intel_guc.h | 6 +-
drivers/gpu/drm/i915/intel_guc_submission.c | 1477 +++++++++++++++++++++++++++
drivers/gpu/drm/i915/intel_guc_submission.h | 81 ++
drivers/gpu/drm/i915/intel_lrc.c | 17 +-
drivers/gpu/drm/i915/intel_ringbuffer.h | 4 +-
drivers/gpu/drm/i915/intel_uc.c | 18 +-
17 files changed, 1602 insertions(+), 1591 deletions(-)
delete mode 100644 drivers/gpu/drm/i915/i915_guc_submission.c
delete mode 100644 drivers/gpu/drm/i915/i915_guc_submission.h
create mode 100644 drivers/gpu/drm/i915/intel_guc_submission.c
create mode 100644 drivers/gpu/drm/i915/intel_guc_submission.h
--
1.9.1
More information about the Intel-gfx
mailing list