[Intel-gfx] [PATCH 04/21] drm/i915: introduce page_sizes field to dev_info
Chris Wilson
chris at chris-wilson.co.uk
Sat Sep 23 08:39:27 UTC 2017
Quoting Matthew Auld (2017-09-22 18:32:35)
> In preparation for huge gtt pages expose page_sizes as part of the
> device info, to indicate the page sizes supported by the HW. Currently
> only 4K is supported.
>
> v2: s/page_size_mask/page_sizes/
>
> Signed-off-by: Matthew Auld <matthew.auld at intel.com>
> Cc: Joonas Lahtinen <joonas.lahtinen at linux.intel.com>
> Cc: Mika Kuoppala <mika.kuoppala at linux.intel.com>
> Cc: Chris Wilson <chris at chris-wilson.co.uk>
> Reviewed-by: Joonas Lahtinen <joonas.lahtinen at linux.intel.com>
> ---
> drivers/gpu/drm/i915/i915_drv.h | 1 +
> drivers/gpu/drm/i915/i915_gem_gtt.h | 7 ++++++-
> drivers/gpu/drm/i915/i915_pci.c | 20 ++++++++++++++++++++
> drivers/gpu/drm/i915/selftests/mock_gem_device.c | 3 +++
> 4 files changed, 30 insertions(+), 1 deletion(-)
>
> diff --git a/drivers/gpu/drm/i915/i915_drv.h b/drivers/gpu/drm/i915/i915_drv.h
> index b59714f0c1bf..869e46306c49 100644
> --- a/drivers/gpu/drm/i915/i915_drv.h
> +++ b/drivers/gpu/drm/i915/i915_drv.h
> @@ -862,6 +862,7 @@ struct intel_device_info {
> u8 gt; /* GT number, 0 if undefined */
> u8 ring_mask; /* Rings supported by the HW */
> u8 num_rings;
> + unsigned int page_sizes; /* page sizes supported by the HW */
Is there a naturally aligned spot we can put this? Eh, the struct is a
mess.
Reviewed-by: Chris Wilson <chris at chris-wilson.co.uk>
-Chris
More information about the Intel-gfx
mailing list