[Intel-gfx] [PATCH i-g-t v2 0/8] lib/igt_kms: Convert properties to be more atomic-like.
Maarten Lankhorst
maarten.lankhorst at linux.intel.com
Wed Sep 27 18:16:27 UTC 2017
Instead of having to special case each property when it's added,
I want to make sure that any test can add arbitrary properties without
having to add too much code. Some of the members I want to expose directly,
and I also add a way to set a blob as property for planes and pipes,
which will be useful for the upcoming plane color management stuff.
Now with bugfixes!
Maarten Lankhorst (8):
tests: Stop looking at plane private members
lib/igt_kms: Change output->pending_crtc_idx_mask to
output->pending_pipe
lib/igt_kms: Commit primary plane when a modeset is forced on a pipe
lib/igt_kms: Rework connector properties to be more atomic, v2.
lib/igt_kms: Rework plane properties to be more atomic, v2.
lib/igt_kms: Rework pipe properties to be more atomic, v2.
igt/kms_rotation_crc : Fix flip tests for sprite plane
tests: Rename kms_pipe_color to kms_color
lib/igt_kms.c | 587 +++++++++++++++-----------------
lib/igt_kms.h | 154 ++++-----
tests/Makefile.sources | 2 +-
tests/kms_atomic_interruptible.c | 20 +-
tests/kms_atomic_transition.c | 123 +++----
tests/kms_busy.c | 7 +-
tests/{kms_pipe_color.c => kms_color.c} | 4 +-
tests/kms_concurrent.c | 4 +-
tests/kms_crtc_background_color.c | 2 +-
tests/kms_cursor_legacy.c | 8 +-
tests/kms_fbc_crc.c | 3 +-
tests/kms_panel_fitting.c | 16 +-
tests/kms_plane_scaling.c | 14 +-
tests/kms_rmfb.c | 2 +-
tests/kms_rotation_crc.c | 37 +-
15 files changed, 463 insertions(+), 520 deletions(-)
rename tests/{kms_pipe_color.c => kms_color.c} (99%)
--
2.14.1
More information about the Intel-gfx
mailing list