[Intel-gfx] [PATCH i-g-t v2 8/8] tests: Rename kms_pipe_color to kms_color

Maarten Lankhorst maarten.lankhorst at linux.intel.com
Wed Sep 27 18:16:35 UTC 2017


Rename kms_pipe_color to kms_color, and rename the invalid tests to pipe-invalid.
To prepare for adding support for plane color management.

Signed-off-by: Maarten Lankhorst <maarten.lankhorst at linux.intel.com>
---
 tests/Makefile.sources                  | 2 +-
 tests/{kms_pipe_color.c => kms_color.c} | 4 ++--
 2 files changed, 3 insertions(+), 3 deletions(-)
 rename tests/{kms_pipe_color.c => kms_color.c} (99%)

diff --git a/tests/Makefile.sources b/tests/Makefile.sources
index 0adc28a014d2..c4d320ebc61b 100644
--- a/tests/Makefile.sources
+++ b/tests/Makefile.sources
@@ -177,6 +177,7 @@ TESTS_progs = \
 	kms_busy \
 	kms_ccs \
 	kms_chv_cursor_fail \
+	kms_color \
 	kms_concurrent \
 	kms_crtc_background_color \
 	kms_cursor_crc \
@@ -197,7 +198,6 @@ TESTS_progs = \
 	kms_mmio_vs_cs_flip \
 	kms_panel_fitting \
 	kms_pipe_b_c_ivb \
-	kms_pipe_color \
 	kms_pipe_crc_basic \
 	kms_plane \
 	kms_plane_lowres \
diff --git a/tests/kms_pipe_color.c b/tests/kms_color.c
similarity index 99%
rename from tests/kms_pipe_color.c
rename to tests/kms_color.c
index ccfc08e6be15..060a60152808 100644
--- a/tests/kms_pipe_color.c
+++ b/tests/kms_color.c
@@ -1205,10 +1205,10 @@ igt_main
 		igt_subtest_group
 			run_tests_for_pipe(&data, pipe);
 
-	igt_subtest_f("invalid-lut-sizes")
+	igt_subtest_f("pipe-invalid-lut-sizes")
 		invalid_lut_sizes(&data);
 
-	igt_subtest_f("invalid-ctm-matrix-sizes")
+	igt_subtest_f("pipe-invalid-ctm-matrix-sizes")
 		invalid_ctm_matrix_sizes(&data);
 
 	igt_fixture {
-- 
2.14.1



More information about the Intel-gfx mailing list