[Intel-gfx] [PATCH 5/9] drm/i915: Move core GuC functions into dedicated file
Sagar Arun Kamble
sagar.a.kamble at intel.com
Sat Sep 30 18:27:15 UTC 2017
On 9/30/2017 11:44 PM, Michal Wajdeczko wrote:
> On Sat, 30 Sep 2017 19:16:42 +0200, Sagar Arun Kamble
> <sagar.a.kamble at intel.com> wrote:
>
>>
>>
>> On 9/30/2017 10:36 PM, Sagar Arun Kamble wrote:
>>>
>>>
>>> On 9/29/2017 11:11 PM, Michal Wajdeczko wrote:
>>>> We want to keep GuC functions together. While here move
>>>> send registers initialization to early init as this is
>>>> one time operation.
>>>>
>>>> Signed-off-by: Michal Wajdeczko <michal.wajdeczko at intel.com>
>>>> Cc: Joonas Lahtinen <joonas.lahtinen at linux.intel.com>
>>>> Cc: Chris Wilson <chris at chris-wilson.co.uk>
>>>> Cc: Sagar Arun Kamble <sagar.a.kamble at intel.com>
>>> <snip>
>>>> +void intel_guc_init_early(struct intel_guc *guc)
>>>> +{
>>>> + intel_guc_ct_init_early(&guc->ct);
>>>> +
>>>> + mutex_init(&guc->send_mutex);
>>>> + guc->send = intel_guc_send_nop;
>>>> + guc->notify = gen8_guc_raise_irq;
>>>> + guc_init_send_regs(guc);
>>> Better to address guc_init_send_regs move in new patch as discussed.
>>> Otherwise overall patch looks good to me.
>> Please s/dev_priv/i915 in entire patch. Missed earlier.
>
> I can't as rename dev_priv as it is required indirect parameter for
>
> #define I915_READ(reg) dev_priv->uncore.funcs.mmio_readl(dev_priv,
> (reg), true)
> ^^^^^^^^ ^^^^^^^^
> #define I915_WRITE(reg, val)
> dev_priv->uncore.funcs.mmio_writel(dev_priv, (reg), (val), true)
> ^^^^^^^^ ^^^^^^^^
>
> Btw, this limitation will make whole dev_priv/i915 cleanup questionable.
Oh. right. Parameterizing I915_READ/WRITE can solve the problem.
Otherwise file has mixed names.
In current patch guc_init_send_regs can have this substitution.
Please address couple of other older minor issues that checkpatch is
complaining about. Had faced during my earlier rework series:
WARNING: line over 80 characters
#151: FILE: drivers/gpu/drm/i915/intel_guc.h:128:
+static inline int intel_guc_send(struct intel_guc *guc, const u32
*action, u32 len)
WARNING: Missing a blank line after declarations
#164: FILE: drivers/gpu/drm/i915/intel_guc.h:141:
+ u32 offset = i915_ggtt_offset(vma);
+ GEM_BUG_ON(offset < GUC_WOPCM_TOP);
>
> Michal
More information about the Intel-gfx
mailing list