[Intel-gfx] [PATCH 05/18] video/hdmi: Add an enum for HDMI packet types

Sharma, Shashank shashank.sharma at intel.com
Thu Dec 20 11:27:34 UTC 2018


Regards

Shashank


On 9/21/2018 12:21 AM, Ville Syrjala wrote:
> From: Ville Syrjälä <ville.syrjala at linux.intel.com>
>
> We'll be wanting to send more than just infoframes over HDMI. So add an
> enum for other packet types.
>
> TODO: Maybe just include the infoframe types in the packet type enum
>        and get rid of the infoframe type enum?
>
> Cc: Thierry Reding <thierry.reding at gmail.com>
> Cc: Hans Verkuil <hans.verkuil at cisco.com>
> Cc: linux-media at vger.kernel.org
> Signed-off-by: Ville Syrjälä <ville.syrjala at linux.intel.com>
> ---
>   include/linux/hdmi.h | 15 +++++++++++++++
>   1 file changed, 15 insertions(+)
>
> diff --git a/include/linux/hdmi.h b/include/linux/hdmi.h
> index c76b50a48e48..80521d9591a1 100644
> --- a/include/linux/hdmi.h
> +++ b/include/linux/hdmi.h
> @@ -27,6 +27,21 @@
>   #include <linux/types.h>
>   #include <linux/device.h>
>   
> +enum hdmi_packet_type {
> +	HDMI_PACKET_TYPE_NULL = 0x00,
> +	HDMI_PACKET_TYPE_AUDIO_CLOCK_REGEN = 0x01,
> +	HDMI_PACKET_TYPE_AUDIO_SAMPLE = 0x02,
> +	HDMI_PACKET_TYPE_GENERAL_CONTROL = 0x03,
> +	HDMI_PACKET_TYPE_AUDIO_CP = 0x04,
Call it TYPE_ACP instead of AUDIO_CP just to be inline with H14b spec 
description ?
> +	HDMI_PACKET_TYPE_ISRC1 = 0x05,
> +	HDMI_PACKET_TYPE_ISRC2 = 0x06,
> +	HDMI_PACKET_TYPE_ONE_BIT_AUDIO_SAMPLE = 0x07,
> +	HDMI_PACKET_TYPE_DST_AUDIO = 0x08,
> +	HDMI_PACKET_TYPE_HBR_AUDIO_STREAM = 0x09,
> +	HDMI_PACKET_TYPE_GAMUT_METADATA = 0x0a,
> +	/* + enum hdmi_infoframe_type */
> +};
> +
With or without the change suggested above:
Reviewed-by: Shashank Sharma <shashank.sharma at intel.com>
>   enum hdmi_infoframe_type {
>   	HDMI_INFOFRAME_TYPE_VENDOR = 0x81,
>   	HDMI_INFOFRAME_TYPE_AVI = 0x82,


More information about the Intel-gfx mailing list